Bug 56375 - Oracle 9i fails to install correctly (error in Oracle text)
Oracle 9i fails to install correctly (error in Oracle text)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.2
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-16 09:49 EST by Nicolas Mailhot
Modified: 2016-11-24 09:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-16 09:49:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2001-11-16 09:49:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [fr] (X11; U; Linux 2.4.13-ac7-lys2 i686; Nav)

Description of problem:
Oracle 9i fails to install on RedHat 7.2 :
the ctxhx command won't run

Since this seems to be a glibc error, glibc version is the same in 7.1 and
7.2 updates and RedHat 7.1 is certified with Oracle 9i there is a problem

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install a new RH 7.2 system, apply upgrades
2. install oracle 9i (you may need to remove -z defs in LD_SELF_CONTAINED
in the genclntsh script)
3. test Oracle text with  ctxhx $ORACLE_HOME/adm/sql/ifsctxtest.doc
test.html
	

Actual Results:  ctxhx: relocation error: $ORACLE_HOME/ctx/lib/libsc_ut.so:
undefined symbol: stat

Expected Results:  Oracle text filter should have converted the test
document

Additional info:

Tests perfomed on the installation computer :

[oracle@localhost oracle]$ ldd $ORACLE_HOME/ctx/bin/ctxhx
libm.so.6 => /lib/i686/libm.so.6 (0x40027000)
libsc_fa.so =>
/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/libsc_fa.so
(0x4004a000)
libsc_ex.so =>
/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/libsc_ex.so
(0x4004f000)
libsc_da.so =>
/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/libsc_da.so
(0x4006d000)
libsc_ut.so =>
/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/libsc_ut.so
(0x40074000)
libsc_ch.so =>
/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/libsc_ch.so
(0x400c2000)
libsc_fi.so =>
/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/libsc_fi.so
(0x400d2000)
libc.so.6 => /lib/i686/libc.so.6 (0x400e6000)
libdl.so.2 => /lib/libdl.so.2 (0x40222000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

[oracle@localhost oracle]$ strings $ORACLE_HOME/ctx/bin/ctxhx|grep libc
libc.so.6
__libc_start_main

[oracle@localhost oracle]$ strace $ORACLE_HOME/ctx/bin/ctxhx 2>&1|grep
^stat
stat64("/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/i686/mmx",
0xbfffe6ac) = -1 ENOENT (No such file or directory)
stat64("/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/i686",
0xbfffe6ac) =
-1 ENOENT (No such file or directory)
stat64("/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib/mmx", 0xbfffe6ac)
=
-1 ENOENT (No such file or directory)
stat64("/var/oracle/ora1/app/oracle/product/9.0.1/ctx/lib",
{st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
stat64("/var/oracle/ora1/app/oracle/product/9.0.1/lib/i686/mmx",
0xbfffe6ac) =
-1 ENOENT (No such file or directory)
stat64("/var/oracle/ora1/app/oracle/product/9.0.1/lib/i686", 0xbfffe6ac) =
-1
ENOENT (No such file or directory)
stat64("/var/oracle/ora1/app/oracle/product/9.0.1/lib/mmx", 0xbfffe6ac) =
-1
ENOENT (No such file or directory)
stat64("/var/oracle/ora1/app/oracle/product/9.0.1/lib",
{st_mode=S_IFDIR|0755,
st_size=4096, ...}) = 0

[oracle@localhost oracle]$ nm --defined-only /lib/i686/libc.so.6|grep
stat64
000df9e4 t ___fxstat64
000dfa34 t ___lxstat64
000df994 t ___xstat64
000df9e4 T __fxstat64@@GLIBC_2.2
000df9e4 T __fxstat64@GLIBC_2.1
000dfa34 T __lxstat64@@GLIBC_2.2
000dfa34 T __lxstat64@GLIBC_2.1
000df9e4 t __old__fxstat64
000dfa34 t __old__lxstat64
000df994 t __old__xstat64
000df994 T __xstat64@@GLIBC_2.2
000df994 T __xstat64@GLIBC_2.1

[oracle@localhost oracle]$ rpm -qa|grep glibc
compat-glibc-6.2-2.1.3.2
glibc-common-2.2.4-19
glibc-2.2.4-19
glibc-kernheaders-2.4-1
glibc-devel-2.2.4-19

[oracle@localhost oracle]$ rpm -V glibc-common glibc-profile glibc
glibc-devel
..?..... /usr/libexec/pt_chown
..?..... /usr/sbin/glibc_post_upgrade

[oracle@localhost oracle]$ uname -a
Linux localhost 2.4.13-ac7-lys2 #2 lun nov 12 11:40:00 CET 2001 i686
unknown

[oracle@localhost oracle]$ rpm -q binutils
binutils-2.11.92.0.7-2

[oracle@localhost oracle]$ rpm -V binutils
[oracle@localhost oracle]$
Comment 1 Jakub Jelinek 2001-11-16 14:25:16 EST
If you get this bug, it means at least one of Oracle's shared libraries was
linked incorrectly (that is, was not linked against -lc).
gcc -shared does this automatically, so it can only happen if someone uses
ld -shared improperly (stat is normally inlined and if something is compiled
without optimizations or inlining doesn't happen for some other reason,
it is defined in /usr/lib/libc_nonshared.a which is linked in when linking
against -lc; but unlike to 7.0 glibc stat is STV_HIDDEN symbol there,
meaning it is private to each library).
All in all, this looks like an Oracle bug which should be reported to Oracle,
not us.

Note You need to log in before you can comment on or make changes to this bug.