Bug 563830 - kcm_kpk_settings.so: undefined symbol
kcm_kpk_settings.so: undefined symbol
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-11 04:46 EST by Martin Kho
Modified: 2010-03-22 18:15 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.6.0-0.8.20100301.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-22 18:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2010-02-11 04:46:02 EST
Description of problem:
kpackagekit crashed standalone and from System Settings. I think it has to do with a new version op PackageKit that was pushed Feb. 10.
The message I get is:
"kpackagekit: symbol lookup error: /usr/lib64/kde4/kcm_kpk_settings.so: undefined symbol: _ZN10PackageKit6Client11getRepoListE6QFlagsINS0_6FilterEE"


Version-Release number of selected component (if applicable):
kpackagekit-0.6.0-0.2.20100111.fc13.x86_64
PackageKit-0.6.2-0.1.20100209git.fc13.x86_64

How reproducible:
Start kpackagekit from K-menu or from System Settings.

  
Actual results:
kpackagekit crashes

Expected results:
kpackagekit starts

Additional info:
Comment 1 Steven M. Parrish 2010-02-15 16:05:53 EST
Will take this to the upstream devs.  kpk 0.6.0 is still under development.

This bug has been triaged

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Bug Zapper 2010-03-15 10:29:50 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Martin Kho 2010-03-22 18:10:22 EDT
Hi,

kpackagekit was updated to version 0.6.0-0.8.20100301.fc13.x86_64
PackageKit was updated to version 0.6.2-1.fc13.x86_64

The issue is solved with these updates. This report can be closed, I suppose.

Thanks,

Martin Kho

Btw. There are a few other issues with these versions, I'll report separately.

Note You need to log in before you can comment on or make changes to this bug.