Bug 56445 - changing /etc/sysconfig/network-scripts/ifcfg-eth0 && /etc/init.d/network restart fails
changing /etc/sysconfig/network-scripts/ifcfg-eth0 && /etc/init.d/network res...
Status: CLOSED DUPLICATE of bug 55404
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-18 13:39 EST by Greg Cope
Modified: 2015-03-04 20:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 17:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Cope 2001-11-18 13:39:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
Changing the IP address in ifcfg-eth0 and then doing a /etc/init.d/network
restart does not reset the IP address (as reported by ifconfig)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. edit /etc/sysconfig/network-scripts/ifcfg-eth0 and change the ip address
2. issue /etc/init.d/network restart
3. check ifconfig for new ipaddress - old one is still being reported /
used.
	

Actual Results:  IP address remains unchanged.

Expected Results:  The new IP address should have been used.

Additional info:

Reproducable on two different machines, with different network addaptors.
Comment 1 Werner Puschitz 2001-11-22 03:21:04 EST
Please check 55404 for my comments on this problem.
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=55404

I provided an explanation and a suggested patch.

Regards,
Werner
Comment 2 Greg Cope 2001-11-22 04:18:38 EST
Sorry duplicate bug - I tried searching but did not find this one!
Comment 3 Phil Knirsch 2002-02-24 12:22:10 EST

*** This bug has been marked as a duplicate of 55404 ***

Note You need to log in before you can comment on or make changes to this bug.