Bug 56448 - Installer hangs after all packages are installed
Summary: Installer hangs after all packages are installed
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-18 19:19 UTC by Need Real Name
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-21 09:00:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-11-18 19:19:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (Win95; I)

Description of problem:
 I choosed Custom Installation, without networks and Boot Disk.
 after anaconda installed all packages, a dialog appeard with text (look 
 Additional info) after that system rebooted.... and nothing worked, so I 
 installed it again but this time as Workstation. 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Traceback (innermost last):
  File 
"/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19, in 
run
    rc = self.todo.doInstall ()
  File 
"/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1964, in 
doInstall
    self.fstab.write (self.instPath)
  File 
"/var/tmp/anaconda-7.1//usr/lib/anaconda/fstab.py", line 885, in write
   
 iutil.mkdirChain(prefix + mntpoint)
  File 
"/var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py", line 237, in 
mkdirChain
    os.mkdir(path, 0755)
OSError: [Errno 5] Input/output error: 
'/mnt/sysimage/mnt'

Local variables in innermost frame:
which: 4
dir: 
/mnt/sysimage/mnt/floppy
elements: ['', 'mnt', 'sysimage', 'mnt', 
'floppy']
path: /mnt/sysimage/mnt

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1024x768'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I412
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10

<failed>

Comment 1 Brent Fox 2001-11-29 15:29:58 UTC
Did you create mount points for any DOS partitions?

Comment 2 Need Real Name 2001-12-02 16:35:17 UTC
No, I don't need DOS Partitions.
I only created one Linux Native(7.5GB Mount point / ) and Linux Swap(512MB) 
partition.

Comment 3 Brent Fox 2001-12-04 04:31:45 UTC
And did the install crash the second time, too?

Comment 4 Need Real Name 2001-12-07 13:18:31 UTC
No.

Comment 5 Brent Fox 2002-01-21 05:05:53 UTC
Hmm...I can't explain why it didn't work the first time but then worked the
second time.  I'm not sure how to proceed since I don't have a reproducible test
case.  Are you seeing any other issues at this time?

Comment 6 Need Real Name 2002-01-21 09:00:35 UTC
No.

Comment 7 Brent Fox 2002-01-21 15:44:07 UTC
Hmm...well, I'm going to close this report now since I can't reproduce the
behavior.  Please reopen this bug if you see the problem reappear in the future.
 Thanks for your report.


Note You need to log in before you can comment on or make changes to this bug.