Bug 56497 - "CURRENT LVS ROUTING TABLE" Always empty on Red Hat Linux versions 7.0, 7.1, or 7.2
"CURRENT LVS ROUTING TABLE" Always empty on Red Hat Linux versions 7.0, 7.1, ...
Status: CLOSED ERRATA
Product: Red Hat High Availability Server
Classification: Retired
Component: piranha (Show other bugs)
beta
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-19 20:13 EST by stevep
Modified: 2007-04-18 12:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-19 20:18:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Corrected version of control.php3 (7.46 KB, text/html)
2001-11-19 20:18 EST, stevep
no flags Details

  None (edit)
Description stevep 2001-11-19 20:13:50 EST
Description of Problem:
The "CURRENT LVS ROUTING TABLE" area in the Control/Monitor page is always
empty on versions of Red Hat Linux 7.0, 7.1, or 7.2. The problem is an
incorrect path in line 215 of /etc/sysconfig/ha/web/secure/control.php3

Version-Release number of selected component (if applicable):
Piranha version = 0.5-8, Red Hat Linux version = 7.2

How Reproducible:
Every Time

Steps to Reproduce:
1.Install Piranha from piranha-0.5.5-8.i386.rpm on HOSTNAME
2.Configure for LVS
3.Start piranha-gui
4.Connect to http://HOSTNAME:3636
5.Login to Piranha
6.Select the control/monitoring tab
 
Actual Results:
The area for "CURRENT LVS ROUTING TABLE" is empty.

Expected Results:
The area for "CURRENT LVS ROUTING TABLE" should contain:

 IP Virtual Server version 0.8.1 (size=65536)                   
Prot LocalAddress:Port Scheduler Flags                         
  -> RemoteAddress:Port             Forward Weight ActiveConn InActConn
TCP  10.2.2.166:80 rr
  -> 10.2.3.4:80                    Masq    9809   0          0         
TCP  10.2.2.166:81 rr

Additional Information:
Line 215 of /etc/sysconfig/ha/web/secure/control.php3 is:                      
              echo `/usr/sbin/ipvsadm -Ln` ;
but should be:
              echo `/sbin/ipvsadm -Ln` ;
Or, ipvsadm should be installed in /usr/sbin instead of /sbin.
Comment 1 stevep 2001-11-19 20:18:11 EST
Created attachment 37984 [details]
Corrected version of control.php3
Comment 2 Phil Copeland 2002-05-09 16:28:59 EDT
Current errata

Note You need to log in before you can comment on or make changes to this bug.