Bug 565498 - User Guide unclear
User Guide unclear
Status: CLOSED ERRATA
Product: Publican
Classification: Community
Component: publican (Show other bugs)
1.6
All Linux
low Severity medium
: ---
: ---
Assigned To: Ruediger Landmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-15 08:58 EST by Christoph Görn
Modified: 2010-11-23 23:20 EST (History)
5 users (show)

See Also:
Fixed In Version: publican-1.5-0.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 22:30:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christoph Görn 2010-02-15 08:58:54 EST
Description of problem: Within Appenix C of the User Guid at http://jfearn.fedorapeople.org/Publican/appe-Users_Guide-publican.cfg_parameters.html it says: "catalogs the path to the DocBook catalog files. (Default for Linux operating systems: /usr/share/publican/xsl ". The path seems to be wrong.


Version-Release number of selected component (if applicable): 1.4


How reproducible: read manual


Steps to Reproduce:
1. open http://jfearn.fedorapeople.org/Publican/appe-Users_Guide-publican.cfg_parameters.html
  
Actual results:


Expected results:


Additional info:
I am pretty unsure if that parameted does something at all... Maybe you could clearify how to add my own catalog files for a docbook xml extension?!
Comment 1 Jeff Fearn 2010-02-20 23:28:56 EST
catalogs is no longer used in Publican, it was used in Publican 0.x because we shipped updated DTDs on some Linux platforms. It must have escaped notice during the Publican 1 rewrite.

I removed all references to catalogs in the code and Users Guide. In the code it was in the cofig file handling code but was not used anywhere else.

You "should" be able to override the system catalog by exporting XML_CATALOG_FILE before calling publican.

FYI to use catalogs to change the DTD being loaded you'd have to be naughty and hijack the DocBook URIs. To actually change the DTD being referenced you'd need to change the hard coded DTDs in lib/Publican/Builder.pm
Comment 2 Fedora Update System 2010-02-26 00:25:03 EST
publican-1.5-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc12
Comment 3 Fedora Update System 2010-02-26 00:28:49 EST
publican-1.5-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc13
Comment 4 Fedora Update System 2010-02-26 00:29:03 EST
publican-1.5-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc11
Comment 5 Fedora Update System 2010-02-26 00:29:10 EST
publican-1.5-0.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc12
Comment 6 Fedora Update System 2010-02-26 00:31:25 EST
publican-1.5-0.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc13
Comment 7 Fedora Update System 2010-02-26 00:35:20 EST
publican-1.5-0.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/publican-1.5-0.fc11
Comment 8 Fedora Update System 2010-02-26 22:29:41 EST
publican-1.5-0.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2010-02-26 22:45:26 EST
publican-1.5-0.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.