This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 565521 - authconfig should better sync login.defs and other files with duplicate settings
authconfig should better sync login.defs and other files with duplicate settings
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
: 628980 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-15 09:59 EST by Petr Šplíchal
Modified: 2016-05-31 21:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: authconfig-6.1.9-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-23 08:58:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2010-02-15 09:59:01 EST
Description of problem:

If /etc/pam.d/system-auth contains md5 as the hash algorithm but
/etc/login.defs specifies "ENCRYPT_METHOD SHA512", calling the:

    authconfig --update --enablemd5

will leave the ENCRYPT_METHOD value in login.defs untouched. This
can cause some tools from the shadow-utils package to behave in an
unexpected way.

Version-Release number of selected component (if applicable):
authconfig-6.0.2-1.el6.x86_64
Comment 1 Bug Zapper 2010-03-15 11:02:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Tomas Mraz 2010-09-01 03:40:56 EDT
*** Bug 628980 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-09-15 10:20:31 EDT
authconfig-6.1.9-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/authconfig-6.1.9-1.fc14
Comment 4 Fedora Update System 2010-09-15 23:29:19 EDT
authconfig-6.1.9-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update authconfig'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/authconfig-6.1.9-1.fc14
Comment 5 Fedora Update System 2010-09-23 08:58:39 EDT
authconfig-6.1.9-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.