Red Hat Bugzilla – Bug 565608
repoquery --whatrequires 'python(abi) = 3.1' broken
Last modified: 2014-01-21 18:13:57 EST
I tried to find out what requires the python 3.1 abi.
-> running "repoquery --whatrequires 'python(abi) = 3.1'"
After that running "repoquery --whatrequires 'python(abi) = 46.9'"
No matter what version you type in, the result is always the same like the output of 2.6 would expect:
"repoquery --whatrequires 'python(abi) = 2.6'"
I don't know how this option --whatrequires is handled internally, but maybe the string is just cut directly before "=" and anything else silently ignored.
confirmed, bizarre - looking into it a bit more
and here's your answer
for prov in provs:
# Only look at the providing name, not the whole version. This
# might occasionally give some false positives but that's
# better than missing ones which it had previously
for pkg in self.pkgSack.searchRequires(prov.split()):
pkgs[pkg.pkgtup] = pkg
that needs to get fixed.
deep and ugly - fixed upstream
(In reply to comment #3)
> deep and ugly - fixed upstream
Thanks for the fast fix.
I noticed this on F-12, but I don't care that much, when this will land in fedora.
-> Set version to 'rawhide'
Thomas, thanks for filing it. It is fixed in rawhide in the place in yum it was busted and will be in repoquery soon.
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.
More information and reason for this action is here:
This is fixed upstrean, so setting to modified, i will be available in next release of yum utils.
This is fixed in update: