Bug 565608 - repoquery --whatrequires 'python(abi) = 3.1' broken
repoquery --whatrequires 'python(abi) = 3.1' broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-15 13:17 EST by Thomas Spura
Modified: 2014-01-21 18:13 EST (History)
4 users (show)

See Also:
Fixed In Version: yum-utils-1.1.26-7.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-26 06:17:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Spura 2010-02-15 13:17:36 EST
I tried to find out what requires the python 3.1 abi.

-> running "repoquery --whatrequires 'python(abi) = 3.1'"

After that running "repoquery --whatrequires 'python(abi) = 46.9'"

No matter what version you type in, the result is always the same like the output of 2.6 would expect:
"repoquery --whatrequires 'python(abi) = 2.6'"

I don't know how this option --whatrequires is handled internally, but maybe the string is just cut directly before "=" and anything else silently ignored.

Version:
yum-utils-1.1.25-1.fc12.noarch
Comment 1 seth vidal 2010-02-15 13:46:03 EST
confirmed, bizarre - looking into it a bit more
Comment 2 seth vidal 2010-02-15 13:50:03 EST
and here's your answer

           for prov in provs:
                # Only look at the providing name, not the whole version. This 
                # might occasionally give some false positives but that's 
                # better than missing ones which it had previously
                for pkg in self.pkgSack.searchRequires(prov.split()[0]):
                    pkgs[pkg.pkgtup] = pkg
                    if self.options.recursive:
                        require_recursive(pkg.name)


that needs to get fixed.
Comment 3 seth vidal 2010-02-15 19:41:58 EST
deep and ugly  - fixed upstream
Comment 4 Thomas Spura 2010-02-17 06:41:13 EST
(In reply to comment #3)
> deep and ugly  - fixed upstream    

Thanks for the fast fix.

I noticed this on F-12, but I don't care that much, when this will land in fedora.

-> Set version to 'rawhide'
Comment 5 seth vidal 2010-02-17 09:37:41 EST
Thomas, thanks for filing it. It is fixed in rawhide in the place in yum it was busted and will be in repoquery soon.
Comment 6 Bug Zapper 2010-03-15 11:03:08 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Tim Lauridsen 2010-04-27 09:45:53 EDT
This is fixed upstrean, so setting to modified, i will be available in next release of yum utils.
Comment 8 Thomas Spura 2010-05-26 06:17:56 EDT
This is fixed in update:
https://admin.fedoraproject.org/updates/yum-utils-1.1.26-7.fc13

Thanks.

Note You need to log in before you can comment on or make changes to this bug.