Bug 56567 - (USB OHCI SIS) usb fails to work (ohci takeover)
(USB OHCI SIS) usb fails to work (ohci takeover)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
high Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-20 20:21 EST by Rafael Moraes
Modified: 2007-03-26 23:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 11:59:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rafael Moraes 2001-11-20 20:21:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
When i load the usb-ohci module for my usb controler on a lmr598 pcchips
board it dosent works... 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.instal linux, so it detects usb controler
2.boot, and it fails 
3.
	

Actual Results:  usb dont work

Expected Results:  usb should work

Additional info:

the logs for the error:

Nov 19 19:33:54 localhost kernel: usb-ohci.c: USB OHCI at membase
0xd0052000, IRQ 9
Nov 19 19:33:54 localhost kernel: usb-ohci.c: usb-00:01.2, Silicon
Integrated Systems [SiS] 7001
Nov 19 19:33:54 localhost kernel: usb-ohci.c: USB HC TakeOver failed!
Nov 19 19:33:54 localhost kernel: usb.c: USB bus -1 deregistered

the line with usb pci location from /proc/pci
  Bus  0, device   1, function  2:
    USB Controller: Silicon Integrated Systems [SiS] 7001 (rev 17).
      IRQ 9.
      Master Capable.  Latency=32.  Max Lat=80.
      Non-prefetchable 32 bit memory at 0xefffe000 [0xefffefff].

results from: modprbe usb-ohci
[root@localhost rcmoraes]# modprobe usb-ohci
/lib/modules/2.4.9-13/kernel/drivers/usb/usb-ohci.o: init_module: No such
deviceHint: insmod errors can be caused by incorrect module parameters,
including invalid IO or IRQ parameters
/lib/modules/2.4.9-13/kernel/drivers/usb/usb-ohci.o: insmod
/lib/modules/2.4.9-13/kernel/drivers/usb/usb-ohci.o failed
/lib/modules/2.4.9-13/kernel/drivers/usb/usb-ohci.o: insmod usb-ohci failed


this machine is a dualbot and usb works fine on windows ME, and worked  
fine in linux redhat 6.2

here is output from uname -a 
Linux localhost.localdomain 2.4.9-13 #1 Tue Oct 30 19:31:55 EST 2001 i586
unknown

Sory for my bad english, its not my native language
Comment 1 Pete Zaitcev 2001-11-21 13:56:20 EST
The code in ohci did not change, so something is fishy.
I am taking over
Comment 2 Rafael Moraes 2002-01-25 09:12:56 EST
hi, there is 3 months with no activity in this bug
have you guys forgot it ? 

Regards
Rafael Moraes
Comment 3 Pete Zaitcev 2002-01-25 13:07:52 EST
Sorry about the wait, always something gets in the way.
It is a rare situation, few people suffer from it...
BTW, did you have a chance to try 2.4.9-21?
Comment 4 Rafael Moraes 2002-01-25 22:23:27 EST
nope, 

i still have the same problem

output from dmesg:
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-ohci.c: USB OHCI at membase 0xe0052000, IRQ 9
usb-ohci.c: usb-00:01.2, Silicon Integrated Systems [SiS] 7001
usb-ohci.c: USB HC TakeOver failed!
usb.c: USB bus -1 deregistered

[root@localhost root]# uname -a
Linux localhost.localdomain 2.4.9-21 #1 Thu Jan 17 13:35:24 EST 2002 i586 unknown

Comment 5 Rafael Moraes 2002-01-25 22:29:50 EST
sory, i think my first mensage is a little unclear

i've tried the 2.4.9-21 kernel, but it still not working


Comment 6 Rafael Moraes 2002-03-08 09:07:22 EST
4 months and 3 kernel releases after this bug still anoyng me
i've tried the 2.4.9-31 kernel, and the same problem stil happenig
why is this bug taking soo long to be fixed ? 
i have some usb devices that cant be used under redhat linux


best regards 
Rafael Moraes
Comment 7 Pete Zaitcev 2002-03-08 13:00:00 EST
Still puzzled.

I saw report about such thing on linux-usb-devel today,
so we may get a better chance on cracking it.
Comment 8 Pete Zaitcev 2002-11-06 23:38:48 EST
Any news? Had a BIOS update yet?
Comment 9 edwin chávez 2003-01-18 19:35:27 EST
I’ve the same problem on a pcchips with the same usb chip : sis 7001
I had find very poor information about this topic
although i found a web page : 
http://www.kernel.org/pub/linux/kernel/people/gregkh/usb/2.5/usb-ohci-hcd-3-
2.5.21.patch
Where they explain: "basically, at least SiS and  OPTi violate the OHCI spec so 
they don't init "by the book"".
they propose several patches but I don’t know if they´re compatible with red 
hat 7.3 and how I can install them. 
Maybe you can understand better than me this topic and help us with this.

The problem is in any computer ( clone: made in house ) with the usb chip sis 
7001, especificly pcchips motherboards and unable them to load successfully any 
usb device from usb mouse to usb pc-to-pc cables.

Thanks in advance.
Comment 10 Pete Zaitcev 2003-01-20 11:53:06 EST
Edwin, please file your own bug, re: OPTi.
Comment 11 Pete Zaitcev 2004-04-19 11:59:01 EDT
I don't think I can do anything about this problem.

Note You need to log in before you can comment on or make changes to this bug.