Bug 56573 - System upgrade from 7.1 - overwrites files belonging to Metro Link Motif version 2.1
System upgrade from 7.1 - overwrites files belonging to Metro Link Motif vers...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: lesstif (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 00:45 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-26 15:18:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-21 00:45:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010808

Description of problem:
During system upgrade from 7.1 to 7.2 - Metro Link Motif packages,
already on system are corrupted when the upgrade process installs
LessTif.  Specifically, the file /usr/bin/mwm belonging to package
motif-mwm-2.1-2glibc is overwritten by the LessTiff version of that file.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Get 7.1. Without LessTif.
2.Install motif from Metro Link (window manager, libraries, development files).
3.Upgrade to 7.2 - Lesstiff selected to satisfy dependencies.
	

Actual Results:  System upgrade happened normally, but found that the Metro
link
Motif Window Manager had been replaced by the LessTiff version.

Expected Results:  A conflict between Lesstif and Metro Link Motif RPM
packages should
have been detected during the upgrade process - the Metro Link Motif
package should not have been corrupted.

Additional info:
Comment 1 Ngo Than 2001-11-26 13:36:13 EST
i don't know about motif from metrolink. we don't have it in our RHL.
To fix this problem, i need more infos about motif packages from metrolink.
Please give name of motif packages and the output of rpm -qpl motif-packages-name
Comment 2 Need Real Name 2001-11-26 15:18:12 EST
$ rpm -qa | grep motif
motif-2.1-2glibc
motif-devel-2.1-2glibc
motif-mwm-2.1-2glibc


The package being corrupted is "motif-mwm-2.1-2glibc".

$ rpm -qil motif-mwm
Name        : motif-mwm                    Relocations: (not relocateable)
Version     : 2.1                               Vendor: Metro Link Incorporated
Release     : 2glibc                        Build Date: Tue Feb 10 11:34:47 1998
Install date: Wed Oct 24 00:57:11 2001      Build Host: build-lin40g.metrolink.com
Group       : X11                           Source RPM: motif-mwm-2.1-2glibc.src.rpm
Size        : 323994                           License: Commercial
Summary     : Motif 2.1 window manager
Description :
This packages contains the popular Motif Window Manager, `mwm'.
/etc/X11/system.mwmrc
/usr/X11R6/bin/mwm
/usr/X11R6/lib/X11/app-defaults/Mwm
/usr/X11R6/man/man1/mwm.1x
/usr/X11R6/man/man5/mwmrc.5x







Comment 3 Ngo Than 2001-11-29 04:50:31 EST
It's fixed in lesstif-0.93.15-2. You will find it in next rawhide release

Note You need to log in before you can comment on or make changes to this bug.