Bug 56579 - RP3 does not have dial button when used as a user.
RP3 does not have dial button when used as a user.
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 07:34 EST by Smiley Ben
Modified: 2007-04-18 12:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:06:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Smiley Ben 2001-11-21 07:34:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011014

Description of problem:
If I run rp3 as a user (i.e. normally) there is no button to connect, nor
is there an option to connect when right clicking on panel applet. I *have*
selected 'user may connect / disconnect' so it is something of a mystery
what is wrong.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run rp3 as user
2. Have the desire to connect, but realise there isn't an option to.

(3. Abandon that, and run kppp as root...)
	

Actual Results:  No option to dial

Expected Results:  User should be allowed to dial up and connect to their ISP

Additional info:
Comment 1 Stan Klein 2001-11-23 11:09:55 EST
I have exactly the same problem.  I have to su to a root-privileged account to
run rp3 properly.  This did not happen in 6.1 and 7.0.
Comment 2 Martin N Dunstan 2001-11-29 07:23:43 EST
I had this problem with RH 7.1 and 7.2: adding rp3 to
the Gnome panel gives me the dialer with no button to
select to connect!

The problem is that rp3-config does not set the
permissions correctly on the ifcfg-ppp* scripts that
it creates in /etc/sysconfig/network-scripts.

If you create a new ppp account and then use rp3 you
are asked to choose ppp0 as the interface rather than
the name you gave rp3-config (eg MyISP).

As root, chmod 755 the ifcfg-ppp* scripts. I've not
tried to see if chmod 644 or even chmod 444 will do
but the other ifcfg-* scripts are 755 by default.

Comment 3 David Kaplan 2001-12-02 15:45:45 EST
I have the same basic problems with rp3 on my system.  I tried changing the
permissions on all the ifcfg scripts that were relevant, but rp3 still doesnt
work.  I am running Redhat 7.2, rp3-1.1.10-3.
Comment 4 Need Real Name 2001-12-24 02:03:09 EST
refer to bug 55584. there is a solution.
Comment 5 Bill Nottingham 2006-08-07 14:44:27 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 6 Bill Nottingham 2006-10-18 12:06:24 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.