Bug 56592 - what will rpm do if I -F *
what will rpm do if I -F *
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 10:41 EST by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 14:29:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-11-21 10:41:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
There's no feature to see what rpm will do without actually doing it.
The -test switch only reports looming errors, a useful function
rpm --test-verbose -Fhv updates/*rpm
could show packages that would be updated if -Fhv were used alone.


Also, please check if stdout is a terminal or redirect. The following 
command line resulted in the following useless output.

find . -name \*rpm -type f |grep -v -e /[i486,i586,athlon]\*/ |grep -v 
kernel | xargs ls -rt | xargs rpm -Fhv | tee ~/rpm-update-`date -I`

Preparing...
###########################################################################
######################## [100%]
###########################################################################
######################## [ 25%]
###########################################################################
######################## [ 50%]
###########################################################################
######################## [ 75%]
###########################################################################
######################## [100%]

Now is there some way for me to tell which packages I just updated?

Regards,
// George

Version-Release number of selected component (if applicable):
RPM version 4.0.2

How reproducible:
Always
Comment 1 Need Real Name 2001-11-21 10:48:40 EST
Correction: this happened on a 6.2 system, but presumed true for 7.2 as well.
Comment 2 Need Real Name 2001-11-21 14:29:34 EST
Similar request for enhanced test function
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=56592

Similar request to add logging enhancement
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=20177 
Comment 3 Jeff Johnson 2001-11-23 15:44:34 EST
If you take the -h off, you will see what package you updated.
Yes, there's a problem with the progress bars if the output
is not to a tty. I have the fix, but removing -h is the workaround
for now.
Comment 4 Need Real Name 2001-11-23 18:56:52 EST
Yes I should have avoided -h here, but the main issue is determining beforehand
which rpms will be installed from a directory of updates when rpm is given -F
There is no clean way to do it.

Since my original post I've learned to use --test -F -vv which contains
quite a lot of info I don't need, but can grep the required info...

find . -name \*rpm -type f |grep -v -e /[i486,i586,athlon]\*/ |grep -v kernel |
xargs rpm --test -Fvv &> temp ; grep package temp | grep files
I was able to determine which packages were upgraded in my original post with
"rpm -qa --last" too.

// George

Note You need to log in before you can comment on or make changes to this bug.