Bug 56593 - umount is improperly allowed for ordinary user
umount is improperly allowed for ordinary user
Status: CLOSED DUPLICATE of bug 58067
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 10:55 EST by Richard D. McRoberts
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-04 15:51:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard D. McRoberts 2001-11-21 10:55:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
/mnt/hdc6 and /dev/hdc6 are flagged in fstab as ext2 with "noauto,owner"
An ordinary user can umount this partition although he does not have
device file ownership as required by the mount manpage.  Only root
can mount it; the lax enforcement is with umount.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.fstab entry /dev/hdc6 /mnt/hdc6 ext2 noauto,owner
2.ordinary user does NOT own the device file as "mount" manpage says
  he would need if he were to be able to mount/unmount it
3.Only root can mount it, but the ordinary user can unmount it
	

Actual Results:  umount succeeded when it shouldn't have

Expected Results:  The ordinary user shouldn't have been allowed to umount
the partition

Additional info:

When I tried to "strace" it, the permission was correctly enforced.
Comment 1 Richard D. McRoberts 2001-11-24 20:02:19 EST
Oops, this should of course have been attributed to component "mount", instead
of to util-linux.
Comment 2 Elliot Lee 2002-01-04 15:51:40 EST
Yikes, thanks. I've got a patch in the works.
Comment 3 Elliot Lee 2002-01-29 16:36:55 EST

*** This bug has been marked as a duplicate of 58067 ***

Note You need to log in before you can comment on or make changes to this bug.