Bug 56610 - Gnome does not work in DirectColor visual
Gnome does not work in DirectColor visual
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gtk+ (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-21 18:08 EST by greg hosler
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-07 12:57:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description greg hosler 2001-11-21 18:08:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-13smp i686; Nav)

Description of problem:
Anybody know why gnome doesn't like to be run on a DirectColor visual ?

I have an application that needs to be run on a DirectColor visual, so I
started up a 2nd X server 24 bit with a DirectColor visual as the default
visual,
and with a gnome session as follows:

        xinit  /usr/bin/gnome-session -- :1 -depth 24 -cc 5

The colors are absolutely horrible. Note that selecting a TrueColor visual
(e.g. "-cc 4" instead of "-cc 5" in the above) works fine.

Any hints as to how to get gnome to work in a DirectColor visual
environemnt ?

I would have thought that since gnome works fine with a PsuedoColor visual,
that
it would have been fine w/ a DirectColor visual.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.xinit  /usr/bin/gnome-session -- :1 -depth 24 -cc 5 (or startx)
2.
3.
	

Actual Results:  gnome screens are absolutele horrible - looks very much
like a colormap problem.

Expected Results:  Nice gnome screens, just like in 8-bit PsuedoColor

Additional info:
Comment 1 Havoc Pennington 2002-02-26 10:19:10 EST
If this is a GNOME systemic bug at this point we'll just let it be fixed by the
move to GNOME 2 when that happens. If it's a GTK problem Owen might want to fix
it in GTK 1.2.11.
Comment 2 Owen Taylor 2003-01-07 12:57:35 EST
Don't really have a suitable test setup for this. We'll hope it has been
fixed between GTK+-1.2 and GTK+-2.2.

Note You need to log in before you can comment on or make changes to this bug.