Bug 566134 - Augeas sudoers lens does not support secure_path
Augeas sudoers lens does not support secure_path
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: augeas (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-17 06:53 EST by Stuart Sears
Modified: 2013-04-30 19:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-22 14:46:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a patch to add "secure_path" as an accepted variable (652 bytes, application/octet-stream)
2010-02-17 06:53 EST, Stuart Sears
no flags Details

  None (edit)
Description Stuart Sears 2010-02-17 06:53:21 EST
Created attachment 394717 [details]
a patch to add "secure_path" as an accepted variable

Description of problem:
Augeas sudoers lens fails to parse standard Fedora 12 /etc/sudoers file.


Version-Release number of selected component (if applicable):
augeas-0.7.0-1.fc12.i686

How reproducible:
Every time

Steps to Reproduce:
1. create an augeas root from /etc (e.g. /tmp/augeas/sandbox)
2. use augtool -b -r /tmp/augeas-sandbox
3. ls /files/etc/sudoers
  
Actual results:
sudoers is not present.

checking the errors:
augtool> match /augeas//error
/augeas/files/etc/sudoers/error = parse_failed

augtool> ls /augeas/files/etc/sudoers/error
pos = 2255
line = 65
char = 0
lens = /usr/share/augeas/lenses/dist/sudoers.aug:478.10-.57:
message = Iterated lens matched less than it should

line 65 of the sudoers file is
Defaults    secure_path = /sbin:/bin:/usr/sbin:/usr/bin

Expected results:
sudoers file is succesfully parsed.
parameter_string_nobool_kw

Additional info:

commenting the offending line out in sudoers causes the parser to succeed.

it appears that the issue is with the secure_path keyword, which is mentioned nowhere in the sudoers lens.

with the attached patch applied (adding | "secure_path" to the parameter_string_nobool_kw) definition seems to fix this.
Comment 1 David Lutterkort 2010-02-22 14:46:49 EST
Fixed upstream with commit c80d1be4. Will be in augeas-0.7.1

Note You need to log in before you can comment on or make changes to this bug.