Bug 56626 - neat exits on startup because of missing kernel file (kernel issue?)
neat exits on startup because of missing kernel file (kernel issue?)
Status: CLOSED DUPLICATE of bug 55760
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-22 10:34 EST by Christopher Blizzard
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-22 10:34:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Blizzard 2001-11-22 10:34:14 EST
When I start up neat I get an error:

[blizzard@face blizzard]$ neat 
Copying ifcfg-eth0 to devices and putting it into the default profile.
Copying /etc/hosts to default profile.
Copying /etc/resolv.conf to default profile.
Traceback (innermost last):
  File "/usr/sbin/neat", line 1094, in ?
    window = mainDialog()
  File "/usr/sbin/neat", line 199, in __init__
    self.load()
  File "/usr/sbin/neat", line 207, in load
    self.loadDevices()
  File "/usr/sbin/neat", line 212, in loadDevices
    devicelist = getDeviceList()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py", li
ne 144, in getDeviceList
    DVList.load()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py", li
ne 59, in load
    self.data[i].load(dev)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDevice.py",
line 1
92, in load
    hwlist = NCHardwareList.getHardwareList()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 260, in getHardwareList
    HWList.load()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py", 
line 116, in load
    modinfo = ConfModInfo()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line
995, 
in __init__
    Conf.__init__(self, filename, '#', '\t ', ' ', create_if_missing=0)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line
180, 
in __init__
    self.read()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line
997, 
in read
    Conf.read(self)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line
258, 
in read
    raise FileMissing, self.filename + ' does not exist.'
Conf.FileMissing: /boot/module-info does not exist.

[blizzard@face boot]$ rpm -q redhat-config-network
redhat-config-network-0.9-1
[blizzard@face boot]$ rpm -q kernel-smp
kernel-smp-2.4.9-13
Comment 1 Trond Eivind Glomsrxd 2001-11-22 12:44:06 EST

*** This bug has been marked as a duplicate of 55760 ***

Note You need to log in before you can comment on or make changes to this bug.