Bug 566353 - su to old accounts extremely slow after Fedora 12 upgrade
su to old accounts extremely slow after Fedora 12 upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-17 23:48 EST by Tim
Modified: 2010-02-19 01:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-18 22:11:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim 2010-02-17 23:48:26 EST
Description of problem:

After a fresh install of Fedora 12 from Fedora 11, followed by restoring user directories from a backup, when using su to log into one of the old accounts, I encounter a long delay (about 23 seconds) before getting the shell prompt. With accounts that I create "fresh" (with useradd) this delay does not occur.

The way the old accounts were restored was (1) copy the data in from the backup, (2) use useradd to create a username with the old uid/gid.

Probably this is not an issue with su itself, but I don't know where else to start.

Version-Release number of selected component (if applicable):

coreutils-7.6-9.fc12.i686

How reproducible:

100% when logging in via su from a terminal window. Graphical logins to the old accounts (by logging out of one and logging into another via Gnome) do not result an in any significant delay.

Steps to Reproduce:
1. su - <username>
2.
3.
  
Actual results:

Very long delay before appearance of shell prompt. Approximately 23 seconds.

Expected results:

Immediate shell prompt.

Additional info:

One other data point: if I attempt to run something like firefox in a "fresh" account, it works without any problem at all. When I try to run firefox after (eventually) logging into one of the old accounts, I get an X error about being unable to access the display. The only way I can succeed in running such programs is to use "xhost +SI:localuser:<name>" as root.
Comment 1 Ondrej Vasik 2010-02-18 01:21:05 EST
Thanks for report, looks similar to https://bugzilla.redhat.com/show_bug.cgi?id=456808 . Could you please try to find out which syscall/librarycall takes so long? I doubt that the problem is directly in su, more probably pam or whatever could affect it.
Comment 2 Tim 2010-02-18 01:35:55 EST
Thank you for the quick reply. It turns out I was able to solve the problem, at least in tests so far, by doing an Selinux relabel. Perhaps there is some difference between the policy shipped with Fedora 12 and the labels that were on the files copied in from the backup.

Maybe this will help with the other bug?

I just took the sledgehammer approach and did

touch /.autorelabel
reboot

It took a while, but all looks good now. Thanks!
Comment 3 Tim 2010-02-18 22:11:53 EST
All seems well now, including the problem with X sessions. I'm not sure if I'm supposed to close these things or if someone there does, but since the menu item is active, I will ;-)
Comment 4 Ondrej Vasik 2010-02-19 01:52:40 EST
Good, yep, you could of course close bugs you have reported. It really looks like it was some SELinux policy discrepancy or whatever caused by update and fixed by relabeling contexts.

Note You need to log in before you can comment on or make changes to this bug.