Bug 56664 - Poor error handling when package already installed.
Poor error handling when package already installed.
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2001-11-23 13:15 EST by Ed McKenzie
Modified: 2015-01-07 18:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-12-03 12:07:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-11-23 13:15:52 EST
If up2date is invoked from the command line with a list of packages 
to install, it bails out if one or more of those packages are already 
installed.  However, it only prints one of the package names, so the 
user has to rerun up2date several times, removing names one by 
one until it's happy.

I'd argue up2date should always just install, dropping installed 
packages from the install list as need be ...
Comment 1 Adrian Likins 2001-12-03 12:07:46 EST
I've heard it argued both ways. The next version of the client
leans more towards what you suggest, but I personally am not
completely convinced thats the right thing to do.

To me, "up2date -u" or "up2date packagename" is meant to be completely
non-interactive, so I tend to think if I tell it "up2date foobar blippyfoo"
and it cant install blippyfoo, then it cant do what I told it to, and it
should fail. 

However, I seem to be in the minority on that one ;->

Either way, it should probabaly give more useful error reports. 

I'll take a look at it for the next version.
Comment 2 Troy 2003-12-06 09:37:30 EST
I have what might be a simular problem. I have redhat 8.0 and run
updates via the update icon. This always worked great until I did the
recent freeX11 update. It downloaded the stuff, then went to the
install screen....the top bar went up to 100% and then the beast froze
up before getting the bottom bar to go to 100%. Now when I run an
up2date it shows I need to get all these freeX fonts, but if I try and
load them an error message comes up that freeX is already installed
(the new version).

This problem also shows when I sign into redhat....it tells me I need
the freeX update, but again when I go to update to it it tells me I
already have it. How do I fix this problem?

Note You need to log in before you can comment on or make changes to this bug.