Bug 56677 - XFree86 4.1-6 can not be built with glide support. It bail out in Glide3
XFree86 4.1-6 can not be built with glide support. It bail out in Glide3
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86 (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-24 02:19 EST by Knut J BJuland
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-02 07:53:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Knut J BJuland 2001-11-24 02:19:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
XFree86 can not be rebuilt with rpmbuild --target=i686 --rebuild
XFree86-4.1-6.src.rpm witout disabling glide support.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild --target=i686 XFree86-4.1.0-6.src.rpm
2.
3.
	

Actual Results:  it bail out before compiling glide3
+ echo 'PARALLEL MAKE ENABLED: numprocs=2'
PARALLEL MAKE ENABLED: numprocs=2
+ pushd Glide3
/usr/src/redhat/BUILD/XFree86-4.1.0/Glide3 /usr/src/redhat/BUILD/XFree86-4.1.0
+ libtoolize --copy --force
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
+ aclocal
+ automake
automake: configure.in: required file `./depcomp' not found
automake: cvg/glide3/src/makefile.autoconf.am: Assembler source seen but
`ASFLAGS' not defined in `configure.in'
automake: h3/glide3/src/makefile.autoconf.am: Assembler source seen but
`ASFLAGS' not defined in `configure.in'
automake: h5/glide3/src/makefile.autoconf.am: Assembler source seen but
`ASFLAGS' not defined in `configure.in'
error: Bad exit status from /var/tmp/rpm-tmp.35199 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.35199 (%build)

Expected Results:  it should compile

Additional info:
Comment 1 Mike A. Harris 2001-12-02 07:53:13 EST
This isn't because of the --target=i686 being passed, it is because
of the broken new autoconf.  I am not quite sure how easy it is to
fix this problem, so currently I am building XFree86 in the 7.2 build
environment to avoid the problem while I get 4.1.99.x bent into shape.

I'm not sure what will happen with Glide3.  Feel free to suggest things
or attach a patch if you're brave.  ;o)

I am considering putting Glide3 back into it's own separate package
possibly, and maybe separating out the 3dfx driver also.  All
just speculation for now though.  Ideas welcome.  Thanks for the
report.
Comment 2 Mike A. Harris 2002-01-23 10:39:54 EST
Glide3 now builds successfully in rawhide as well.

Note You need to log in before you can comment on or make changes to this bug.