Bug 56682 - use local decimal signs and time separators
use local decimal signs and time separators
Status: CLOSED DUPLICATE of bug 16896
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-24 12:14 EST by Hakon
Modified: 2007-03-26 23:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hakon 2001-11-24 12:14:49 EST
Description of Problem: The installer doesn't use L10N adapted decimal 
signs and time separators

Version-Release number of selected component (if applicable): 7.2


How Reproducible:


Steps to Reproduce:
1. Run (graphical) installer
2. Choose a certain language
3. Check the figures

Actual Results: e.g. 1,000,000 bytes ; 1:00:10 remaining


Expected Results: e.g. 1 000 000 bytes ; 1.00.10 ...
Each language should have a table of settings

Additional Information: This may not seem very important, but if you have 
already gone half-way by translating the dialogs, why not make it complete?
Comment 1 Brent Fox 2001-11-29 11:07:19 EST
I would need to know which languages are appropriate for that notation.  Can you
help me out there?
Comment 2 Hakon 2001-11-29 16:39:36 EST
Well I've looked around the web and found nothing. :(
But since KDE allows these kind of settings in their control panel, they're 
likely to have some resources. I wouldn't know exactly where to go 
unfortunately, but I'll look around.
Comment 3 Hakon 2001-12-08 04:47:35 EST
Maybe the easiest way (although not so convenient) would be to open the control 
panel in Windows, and choose National Settings (or something like that).
Then while browsing the different locales, these items are displayed.
One thing only, I don't think this affects the time separator.
Otherwise there must be some fact book or something covering this.
Comment 4 Miloslav Trmac 2002-02-11 20:41:24 EST
You can get all the information from glibc's locale database
(setlocale(), strftime(), printf() with "%'f"), all you need
is the right LC_xx value.
I have no idea how difficult is this in Python, but I assume
it can be done.
Comment 5 Michael Fulbright 2003-03-04 16:41:41 EST

*** This bug has been marked as a duplicate of 16896 ***
Comment 6 Red Hat Bugzilla 2006-02-21 13:48:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.