Bug 566844 - augeas doesn't handle empty entry
augeas doesn't handle empty entry
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: augeas (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-19 17:38 EST by Mike Burns
Modified: 2010-06-30 18:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: augeas-0.7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 18:16:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2010-02-19 17:38:20 EST
Description of problem:
augeas fails on a blank line

Version-Release number of selected component (if applicable):
augeas-0.7.0-1.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1.run augtool
2.hit enter

  
Actual results:
Unknown command error

$ augtool 
augtool> 
Unknown command ''

Expected results:
as in previous versions, no output at all

$ augtool 
augtool> 
augtool>

Additional info:
Comment 1 David Lutterkort 2010-02-22 15:04:13 EST
Fixed with commit 6c7f09a9 upstream

This makes augeas treat empty lines from stdin the same as comments, i.e. ignore them.

augtool will still complain when you run 'augtool ""', since that generally indicates some problem higher up
Comment 2 David Lutterkort 2010-06-30 18:16:53 EDT
Fixed in augeas-0.7.1 which has been available for a while

Note You need to log in before you can comment on or make changes to this bug.