Bug 567088 - does not show installed "xterm"
Summary: does not show installed "xterm"
Status: CLOSED DUPLICATE of bug 607018
Alias: None
Product: Fedora
Classification: Fedora
Component: xterm   
(Show other bugs)
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-21 15:58 UTC by Richard Z.
Modified: 2010-06-25 07:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 07:16:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Z. 2010-02-21 15:58:25 UTC
Description of problem:

xterm package is installed, /usr/share/applications/fedora-xterm.desktop exists but I do not see an entry in either Lancelot nor kde-application launcher. Searching in text search field does not work either.

Sorry to file it here, seems more of a generic KDE problem or perhaps xterm one but I was not sure where else to file it.

Version-Release number of selected component (if applicable):
Up to date F12

Comment 1 john5342 2010-06-22 23:04:37 UTC
It isn't supposed to show up. The relevant desktop file (in xterm package)
contains "NoDisplay=true" which according to [1] means it shouldn't be
displayed. If anything this is a bug in gnome (for showing it when it shouldn't) or xterm (for using NoDisplay=true). Both kde and gnome have
better alternatives. In the case of kde, konsole.

[1] - http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s05.html

Comment 2 Richard Z. 2010-06-22 23:42:43 UTC
thanks for the info - so it is a bug in xterm. I know that kde and gnome have alternatives but obviously have installed xterm for a reason. kde and gnome also have alternatives to vim and emacs and yet both are configured to display.

Comment 3 Thomas E. Dickey 2010-06-23 08:26:24 UTC
The upstream xterm sources don't contain a setting for NoDisplay,
and the fdo url cited doesn't give a default value for that.
Presumably it defaults to NoDisplay=YES, since I don't recall
Red Hat patching the desktop files.  (I can change it, subject
to the usual problem with fdo ongoing incompatibilities with
"obsolete" versions).

Comment 4 Thomas E. Dickey 2010-06-23 08:53:15 UTC
I have a Fedora12 for checking - it's as reported.

I recall that Red Hat delivered a desktop file, which was one
of the ones that I noticed before adding desktop files to xterm
in patch #226 (2007/6/17).  Mandriva uses these files, and so
does SuSE.  (The latter changes the icon - not everyone likes
the ones I made).  So it looks like a Red Hat-specific bug.

Comment 5 Kevin Kofler 2010-06-25 00:21:03 UTC
It's Fedora-specific and it's an intentional decision to hide it, see bug 231000. But it is arguably a violation of our packaging guidelines. All GUI apps are supposed to have menu entries.

Comment 6 Miroslav Lichvar 2010-06-25 07:16:19 UTC

*** This bug has been marked as a duplicate of bug 607018 ***


Note You need to log in before you can comment on or make changes to this bug.