Bug 56712 - Png migration breaks perl-gd and gnome apps building
Png migration breaks perl-gd and gnome apps building
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-libs (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Mason
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-26 05:10 EST by Nicolas Mailhot
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 08:18:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2001-11-26 05:10:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011123

Description of problem:
Libpng migration still incomplete and breaking many things :

* the gnome rpms are still /usr/lib/libpng.so.2 based. This means they are
unfit to serve as base to compile any gnome app that uses libpng (galeon,
chbg...). Since png is the image format of choice for gnome, that's a lot
of apps.

* it breaks the perl-gd rpm (tested with bugzilla charting component)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Try to compile any new png-aware gnome app and then look at any png (galeon
is a good example).

Try to generate a chart in bugzilla
	

Actual Results:  No png display, lots of png conflicts in the console

Expected Results:  Displaying/Generation of good pngs

Additional info:

Since that's rawhide, some breakage is expected however these problems
persist after quite a long time

The problem is especially accute for gnome, since you can't really expect
rawhide users not to rebuild their additionnal gnome packages on rawhide,
that's usually the only way to get them to work.
Comment 1 Bernhard Rosenkraenzer 2001-11-26 06:50:05 EST
The applications linking to libpng have to be recompiled.

AFAIK the holdup with gnome* is that it won't compile with the current 
versions of autoconf/automake.

Simply install the libpng10 compat package for now.
Comment 2 Nicolas Mailhot 2001-11-26 08:29:38 EST
The problem with gnome* is that if you get galeon for example and try to
recompile it some parts of it will try to use the new libpng, others the
gnome-one resulting in an awfull mess. Same for chbg.
Comment 3 Nicolas Mailhot 2002-12-19 17:56:33 EST
This bug should be closed IMHO. Too old
Comment 4 Nicolas Mailhot 2004-03-11 08:18:19 EST
Yeah - bugzilla resurected old bugs and I can close them now !

Note You need to log in before you can comment on or make changes to this bug.