Bug 56715 - "gcc-2.96-99 " -O2 -mcpu=i686 -ffast-math" produces broken code
"gcc-2.96-99 " -O2 -mcpu=i686 -ffast-math" produces broken code
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-26 06:14 EST by ellson
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 20:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
source file (570 bytes, text/plain)
2001-11-26 06:16 EST, ellson
no flags Details
Makefile (157 bytes, text/plain)
2001-11-26 06:17 EST, ellson
no flags Details

  None (edit)
Description ellson 2001-11-26 06:14:21 EST
Description of Problem:
"-O2 -mcpu=i686 -ffast-math" produces broken code

Version-Release number of selected component (if applicable):
gcc-2.96-99

How Reproducible:
100%


Steps to Reproduce:
1.make attached example 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Problem does not exist in gcc-3.0.2 or in egcs-2.91.66
Comment 1 ellson 2001-11-26 06:16:23 EST
Created attachment 38545 [details]
source file
Comment 2 ellson 2001-11-26 06:17:35 EST
Created attachment 38547 [details]
Makefile
Comment 3 Richard Henderson 2004-10-01 20:56:14 EDT
I can't reproduce this with gcc 3.2, but I suspect that this is

  http://gcc.gnu.org/PR323

which is not taking into account (allowed) extra computational
precision.

Note You need to log in before you can comment on or make changes to this bug.