Bug 56730 - SMP problem with either pcmcia or wvlan_cs driver
SMP problem with either pcmcia or wvlan_cs driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-26 11:27 EST by James Manning
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-28 09:43:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2001-11-26 11:27:48 EST
NOTE: this may be better against just kernel.  I'm not sure,
since I don't know whether it's kernel pcmcia or the wvlan_cs driver
that's at fault yet.

NOTE: hardware is the same as bug #30839 - the server is a dual celery

Description of Problem:
As per Alan's note on testers-list awhile back, with the dual
celery's upgrade to RH 7.2, I went back to an SMP kernel.  I had
gone to a UP kernel when I installed the PCI-PCMCIA bridge before
since PCMCIA wasn't SMP-safe at the time.  Since the switch back
to SMP, everything is fine with the wireless link over light
loads (web browsing, ssh sessions).  Under heavy network i/o loads, 
the flow of data pauses of about 3-5 seconds a few times each minute 
with the wvlan_cs driver having to restart things.  As soon as I went
back to a UP kernel, not a single timeout - rock solid performance
over hours of high network i/o load.

Nov 26 02:25:16 bp6 kernel: NETDEV WATCHDOG: eth2: transmit timed out
Nov 26 02:25:16 bp6 kernel: wvlan_cs: eth2 Tx timed out! Resetting card
Nov 26 02:25:16 bp6 kernel: wvlan_cs: MAC address on eth2 is 00 02 2d 09 
35 46
Nov 26 02:25:16 bp6 kernel: wvlan_cs: Found firmware 0x7001C (vendor 1) - 
Firmwa
re capabilities : 1-2-1-1-1
Nov 26 02:25:16 bp6 kernel: wvlan_cs: Valid channels: 1 2 3 4 5 6 7 8 9 10 
11
Nov 26 02:25:32 bp6 kernel: NETDEV WATCHDOG: eth2: transmit timed out
Nov 26 02:25:32 bp6 kernel: wvlan_cs: eth2 Tx timed out! Resetting card
Nov 26 02:25:32 bp6 kernel: wvlan_cs: MAC address on eth2 is 00 02 2d 09 
35 46
Nov 26 02:25:32 bp6 kernel: wvlan_cs: Found firmware 0x7001C (vendor 1) - 
Firmwa
re capabilities : 1-2-1-1-1
Nov 26 02:25:32 bp6 kernel: wvlan_cs: Valid channels: 1 2 3 4 5 6 7 8 9 10 
11
Nov 26 02:25:40 bp6 kernel: NETDEV WATCHDOG: eth2: transmit timed out
Nov 26 02:25:40 bp6 kernel: wvlan_cs: eth2 Tx timed out! Resetting card
Nov 26 02:25:40 bp6 kernel: wvlan_cs: MAC address on eth2 is 00 02 2d 09 
35 46
Nov 26 02:25:40 bp6 kernel: wvlan_cs: Found firmware 0x7001C (vendor 1) - 
Firmwa
re capabilities : 1-2-1-1-1
Nov 26 02:25:40 bp6 kernel: wvlan_cs: Valid channels: 1 2 3 4 5 6 7 8 9 10 
11
Nov 26 02:25:56 bp6 kernel: NETDEV WATCHDOG: eth2: transmit timed out
Nov 26 02:25:56 bp6 kernel: wvlan_cs: eth2 Tx timed out! Resetting card
Nov 26 02:25:56 bp6 kernel: wvlan_cs: MAC address on eth2 is 00 02 2d 09 
35 46
Nov 26 02:25:56 bp6 kernel: wvlan_cs: Found firmware 0x7001C (vendor 1) - 
Firmwa
re capabilities : 1-2-1-1-1
Nov 26 02:25:56 bp6 kernel: wvlan_cs: Valid channels: 1 2 3 4 5 6 7 8 9 10 
11
Nov 26 02:26:04 bp6 kernel: NETDEV WATCHDOG: eth2: transmit timed out
Nov 26 02:26:04 bp6 kernel: wvlan_cs: eth2 Tx timed out! Resetting card
Nov 26 02:26:05 bp6 kernel: wvlan_cs: MAC address on eth2 is 00 02 2d 09 
35 46
Nov 26 02:26:05 bp6 kernel: wvlan_cs: Found firmware 0x7001C (vendor 1) - 
Firmwa
re capabilities : 1-2-1-1-1
Nov 26 02:26:05 bp6 kernel: wvlan_cs: Valid channels: 1 2 3 4 5 6 7 8 9 10 
11
Nov 26 02:26:13 bp6 kernel: NETDEV WATCHDOG: eth2: transmit timed out
Nov 26 02:26:13 bp6 kernel: wvlan_cs: eth2 Tx timed out! Resetting card
Nov 26 02:26:13 bp6 kernel: wvlan_cs: MAC address on eth2 is 00 02 2d 09 
35 46
Nov 26 02:26:13 bp6 kernel: wvlan_cs: Found firmware 0x7001C (vendor 1) - 
Firmwa
re capabilities : 1-2-1-1-1
Nov 26 02:26:13 bp6 kernel: wvlan_cs: Valid channels: 1 2 3 4 5 6 7 8 9 10 
11


Version-Release number of selected component (if applicable):
kernel-2.4.7-10

How Reproducible:
100%

Steps to Reproduce:
1. SMP kernel
2. wvlan_cs in ad-hoc mode
3. high link load

NOTE: I'll try on the update kernel if desired, but nothing
seems to stick out that's related in the 2.4.9-7 changelog 
since the wvlan_cs update back on Aug 15
Comment 1 James Manning 2001-11-27 23:50:27 EST
Confirmed the same behavior on the update kernels
Comment 2 Arjan van de Ven 2001-11-28 03:41:32 EST
Can you try the orinoco driver? It's the "new" driver for mostly the same
hardware and is going to replace wvlan_cs eventually..
Comment 3 James Manning 2001-11-28 09:43:23 EST
Tons better - none of the card resets and hiccups, but there
might still be something wrong with it.  While fetching 2.5.0
source over the link:

Nov 28 09:35:23 bp6 kernel: eth2: Oversized frame received (2828 bytes)
Nov 28 09:35:45 bp6 kernel: eth2: Undecryptable frame on Rx. Frame dropped.
Nov 28 09:35:51 bp6 kernel: eth2: Oversized frame received (12336 bytes)
Nov 28 09:35:52 bp6 kernel: eth2: Undecryptable frame on Rx. Frame dropped.
Nov 28 09:35:58 bp6 kernel: eth2: Unknown Rx error (0x3). Frame dropped.
Nov 28 09:36:02 bp6 kernel: eth2: Undecryptable frame on Rx. Frame dropped.
Nov 28 09:36:10 bp6 kernel: eth2: Oversized frame received (30032 bytes)
Nov 28 09:36:13 bp6 kernel: eth2: Unknown Rx error (0x3). Frame dropped.
Nov 28 09:36:42 bp6 kernel: eth2: Undecryptable frame on Rx. Frame dropped.
Nov 28 09:36:52 bp6 kernel: eth2: Oversized frame received (17973 bytes)
Nov 28 09:37:03 bp6 kernel: eth2: Oversized frame received (43433 bytes)
Nov 28 09:37:09 bp6 kernel: eth2: Undecryptable frame on Rx. Frame dropped.
Nov 28 09:37:27 bp6 kernel: eth2: Oversized frame received (62451 bytes)
Nov 28 09:37:30 bp6 kernel: eth2: Undecryptable frame on Rx. Frame dropped.
Nov 28 09:38:11 bp6 kernel: eth2: Oversized frame received (20046 bytes)
Nov 28 09:38:20 bp6 kernel: eth2: Undecryptable frame on Rx. Frame dropped.

I'll try updating the server-side card to firmware 7.52 (client side
is already updated, and maybe it includes large frame support)  I paste
this here mainly in case it's a known issue or known driver issue :)

Note You need to log in before you can comment on or make changes to this bug.