This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 56749 - OpenLDAP looping due to EAGAIN on socket write.
OpenLDAP looping due to EAGAIN on socket write.
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-26 16:49 EST by John Dalbec
Modified: 2014-08-31 19:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 13:17:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of 'rpm -qa' since I'm not completely on 7.1 or 7.2 (8.66 KB, text/plain)
2001-11-26 16:51 EST, John Dalbec
no flags Details
Slapd strace during 'test.pl' run. (10M) (10.09 MB, text/plain)
2001-11-26 16:55 EST, John Dalbec
no flags Details
The 'test.pl' script. (853 bytes, text/plain)
2001-11-26 16:56 EST, John Dalbec
no flags Details
Strace of 'test.pl' while running. (112.19 KB, text/plain)
2001-11-26 16:57 EST, John Dalbec
no flags Details

  None (edit)
Description John Dalbec 2001-11-26 16:49:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (Windows NT 5.0; U)

Description of problem:
I have a large perl script which I have distilled down to the attached file 'test.pl'.  When I try to run the script, it hangs at the first account 
defined to LDAP.  (I have removed the "system" accounts (root, bin, ...) from LDAP since (for example) I'm thinking of using separate root 
passwords on the various machines.)  Running strace shows the client hanging while the server keeps trying to write to a socket and 
getting EAGAIN.  If this is allowed to continue, slapd becomes unavailable and the only recourse is to go to the console and reboot by 
Ctrl-Alt-Del (or the gdm login window).  I run the client and the server on the same machine;  there is a PostgreSQL database that the large 
perl script needs to access on that machine.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install 7.1
2. Upgrade nss_ldap, openldap, openssl, ... to 7.2.
3. Install the perl-ldap distribution from CPAN together with its prerequisites.
4. Run 'test.pl'.
	

Actual Results:  The users in /etc/passwd (but not on LDAP) are printed; users defined only on LDAP are not printed - the program hangs 
at that point.

Expected Results:  The full list of users should be printed.

Additional info:

See attached files.
Comment 1 John Dalbec 2001-11-26 16:51:06 EST
Created attachment 38685 [details]
Output of 'rpm -qa' since I'm not completely on 7.1 or 7.2
Comment 2 John Dalbec 2001-11-26 16:55:14 EST
Created attachment 38686 [details]
Slapd strace during 'test.pl' run. (10M)
Comment 3 John Dalbec 2001-11-26 16:56:26 EST
Created attachment 38687 [details]
The 'test.pl' script.
Comment 4 John Dalbec 2001-11-26 16:57:49 EST
Created attachment 38688 [details]
Strace of 'test.pl' while running.
Comment 5 Bill Nottingham 2006-08-07 15:59:02 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 6 Bill Nottingham 2006-10-18 13:17:43 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.