Bug 56755 - Support jisx0213 codeset
Summary: Support jisx0213 codeset
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-27 00:38 UTC by Nakai
Modified: 2016-11-24 14:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-03 09:40:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nakai 2001-11-27 00:38:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
There are popular charactors in jisx0213, like circle digit charactors, but
glibc doesn't support
them and keeps Linux sucks. It should support it. It affects all iconv and
mb functions in glibc,
X, and GTK+, GNOME.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to use circle digits in GTK+
2.Shoot
3.
	

Actual Results:  iconv abort at the char, and gdk_mbstowcs ignores.

Additional info:

Comment 1 Jakub Jelinek 2001-11-27 21:23:36 UTC
In order to support it, I need complete character set definition.
I found they should be available at http://jcs.aa.tufs.ac.jp/,
but since the site is in japanesse, I cannot do anything.
So, can you please provide full jisx0213 definition in the format
of /usr/share/i18n/charmaps/ files (using standard Unicode character names)?

Comment 2 Ulrich Drepper 2003-10-03 09:40:12 UTC
We do have JIX0213 support for some time now.


Note You need to log in before you can comment on or make changes to this bug.