Bug 56778 - mkdosfs: unable to allocate space for FAT image in memory
mkdosfs: unable to allocate space for FAT image in memory
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: dosfstools (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-27 10:10 EST by Xavier Poinsard
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 17:40:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Poinsard 2001-11-27 10:10:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.6)
Gecko/20011120

Description of problem:
When trying to create a boot disk using mkbootdisk, it fails with :
 mkbootdisk --verbose -v 2.4.9-13 --device /dev/fd0H1440 
Insert a disk in /dev/fd0H1440. Any information on the disk will be lost.
Press <Enter> to continue or ^C to abort: 
Formatting /dev/fd0H1440... mkdosfs: unable to allocate space for FAT
image in memory
Failed to format /dev/fd0H1440


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.mkbootdisk --verbose -v 2.4.9-13 --device /dev/fd0H1440
2.OR
3. mkdosfs -v /dev/fd0H1440
	

Actual Results:  Insert a disk in /dev/fd0H1440. Any information on the
disk will be lost.
Press <Enter> to continue or ^C to abort: 
Formatting /dev/fd0H1440... mkdosfs: unable to allocate space for FAT
image in memory
Failed to format /dev/fd0H1440

OR

mkdosfs 2.7 (14 Feb 2001)
/dev/fd0H1440 has 2 heads and 18 sectors per track,
logical sector size is 512,
using 0xf0 media descriptor, with 0 sectors;
file system has 2 16-bit FATs and 2 sectors per cluster.
FAT size is -32639 sectors, and provides 32631 clusters.
Root directory contains 224 slots.
Volume ID is 3c03ab5e, no volume label.
mkdosfs: unable to allocate space for FAT image in memory


Expected Results:  something like "done"

Additional info:

 uname -a : Linux otto 2.4.9-13enterprise #1 SMP Tue Oct 30 19:34:18 EST
2001 i686 unknown
Comment 1 Matt Wilson 2003-10-09 17:40:13 EDT
I can't reproduce this.

Note You need to log in before you can comment on or make changes to this bug.