Bug 567796 - Kpackagekitsmarticon crashed after update
Kpackagekitsmarticon crashed after update
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-23 17:30 EST by Martin Kho
Modified: 2010-03-12 20:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-12 20:38:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kcrash report kpackagekitsmarticon 2010 Feb. 02 (4.37 KB, application/octet-stream)
2010-02-23 17:30 EST, Martin Kho
no flags Details

  None (edit)
Description Martin Kho 2010-02-23 17:30:51 EST
Created attachment 395845 [details]
Kcrash report kpackagekitsmarticon 2010 Feb. 02

Description of problem:
A few minutes after an update session was finished kpackagekitsmarticon crashed. This not always happens. The first time it crashed was on Feb 2, 2010. The next one appeared Feb. 22, 2010. Seven update didn't crash kpackagekitsmarticon. The last time, kcrash showed an empty dump, although the right debuginfo packages were installed. May be abrt is interfering in some way? I'll attach the crash report from Feb. 2, 2010.

Version-Release number of selected component (if applicable):
kpackagekit-0.5.4-2.fc12.x86_64
PackageKit-0.5.6-1.fc12.x86_64

How reproducible:
Very difficult :-( It's just a matter of waiting till kpackagekitsmarticon will crash.

  
Actual results:
kpackagekitsmarticon crashes

Expected results:
kpackagekitsmarticon doesn't crash

Additional info:

Bug report #551500 comment #30 contains an output that seems relevant to this report.
Comment 1 Steven M. Parrish 2010-02-27 21:42:05 EST
Thank you for taking the time to report this issue to us.  This is an issue which is best addressed by the upstream developers.

Please file a report at bugs.kde.org , and when done add the upstream report info to this report.

We will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Martin Kho 2010-03-01 12:48:27 EST
Hi Steven,

I'll file a bug report at bugs.kde.org as soon as a get a new crash report. Of course, a crash will never happen again, I hope :-) I've disable abrt for now, so it wont interfere with KCrash.

You'll hear from me.

Martin Kho
Comment 3 Kevin Kofler 2010-03-02 00:42:26 EST
Well, actually if ABRT catches the bug, that means KCrash didn't intercept it for whatever reason (the app might not be a KApplication, or KCrash is disabled globally or for the app, etc.).
Comment 4 Kevin Kofler 2010-03-02 00:43:44 EST
And I don't think KCrash showing an empty dump has anything to do with ABRT.
Comment 5 Martin Kho 2010-03-02 04:07:47 EST
Hi,

KCrash disabled globally? How can KCrash be disabled/enabled?

Thanks,

Martin Kho
Comment 6 Kevin Kofler 2010-03-02 04:15:13 EST
There's some environment variable you can set to disable it. In your case it's actually enabled (as is the default).
Comment 7 Martin Kho 2010-03-03 04:34:16 EST
Hi,

I have had no more crashes since Feb. 23. Till today there were five update session. Some asked to reboot, others didn't. Never got a crash. It looks like something has 'solved' the issue. So, this report can be closed I suppose?

Martin Kho

p.s.  I didn't open a report at bugs.kde.org, because there is nothing to file :-)
Comment 8 Steven M. Parrish 2010-03-12 20:38:01 EST
Martin based on your comments going to close this for now.  Please feel free to reopen should the problem return.

Steven M. Parrish
KDE & Packagekit Triager 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.