Bug 567854 - cups 1.4 license conflict: GPL and BSD-With-Advertising
Summary: cups 1.4 license conflict: GPL and BSD-With-Advertising
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-24 06:03 UTC by Julius Davies
Modified: 2010-03-01 15:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-01 15:39:26 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CUPS Bugs and Features 3509 0 None None None Never

Description Julius Davies 2010-02-24 06:03:19 UTC
Description of problem:  cups 1.4 license conflict: GPL and BSD-With-Advertising

Version-Release number of selected component (if applicable):
Cups 1.4 and previous have this problem.
Cups 1.5 (trunk) is fixed.

How reproducible:
100%

Steps to Reproduce:
1.  Download Cups 1.4 source code

2.  Notice the BSD-With-Advertising license in the following three files:
backend/scsi.c
backend/scsi-irix.c
backend/scsi-linux.c
  
3.  Notice that UC-Berkeley nor NetBSD are copyright holder, so code cannot be relicensed to remove advertising clause. ( https://fedoraproject.org/wiki/Licensing/FAQ#What.27s_the_deal_with_the_BSD_with_advertising_license.3F )




Additional info:

Doesn't apply in Cups Trunk (presumably Cups 1.5):
http://www.cups.org/str.php?L3500

Cups won't fix in Cups 1.4, but encourage distributions to remove scsi*.c if so desired:
http://www.cups.org/str.php?L3509

Comment 1 Tim Waugh 2010-02-24 12:38:00 UTC
I've asked for direction from Fedora legal on this.

Comment 2 Tim Waugh 2010-03-01 15:39:26 UTC
These files only link against the LGPLv2 parts of cups.


Note You need to log in before you can comment on or make changes to this bug.