Bug 56788 - random Gui lockups
random Gui lockups
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-27 13:28 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 12:24:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server config file (3.65 KB, text/plain)
2001-12-03 19:32 EST, Need Real Name
no flags Details
XFree86 log file (21.54 KB, text/plain)
2001-12-03 19:35 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-11-27 13:28:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (Win95; U ;Nav)

Description of problem:
                                                       
I'm running RH7.2 w/ 128 mb RAM and a Matrox Mystique video card w/ 2 mb of memory on a PII 350 box. Runs fine in level 3 but when in level 5 with
Gnome or KDE I get random lockups with the mouse buttons and keyboard dead. The cursor doesn't freeze, but nothing highlights when the cursor is on it
and the buttons are dead. I can't even Ctrl+Alt+ Delete or Ctrl+Alt+ Backspace. One thing I've noticed is that it takes much longer to freeze
when I run in 8 bit color than in 16 bit. According to the Redhat hardware compatibility list, my card is compatible w/ RH7.2, but I'm beginning
to wonder. This is the same box that I ran a highly tweaked RH6.0 on for over a year with no problems, but that was with XFree86 3.x. RH7.2 runs 
XFree86 
4.x and I'm wondering if it requires more video memory than I have.

I've been communicating back and forth with support for 3 weeks with no results. Their last suggestion was:
    
>Usually the solution for lower RAM is to use the other mode or lower bit mode.  
>If the issue still persists, we recommend posting it to bugzilla entry because 
>we already tried various solutions such as using the lowest mode, using the old 
>server, and others.  This can also be due to bug errors which our System 
>Developers may assist you more.


   




                                            






 
 

                                                                           
                                                                                     



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. startx
2. log in to run level 5
3.
	

Actual Results:  mouse buttons and keyboard freezes after random time iterval

Expected Results:  mouse buttons and keyboard should function normally

Additional info:
Comment 1 Mike A. Harris 2001-12-02 08:03:54 EST
Please attach your X server logs and config files using the
link below.
Comment 2 Need Real Name 2001-12-03 19:26:36 EST
got a problem with sending the log & config file. I have to do it from w95 as I'm having problems getting wvdial in linux to work. I copied the files to my vfat partition and 
put them in a directory, but when I tried to create the attachment it said the directory was empty. I'm snowed because they are plain text files.
Comment 3 Need Real Name 2001-12-03 19:32:33 EST
Created attachment 39528 [details]
X server config file
Comment 4 Need Real Name 2001-12-03 19:35:07 EST
Created attachment 39529 [details]
XFree86 log file
Comment 5 Need Real Name 2001-12-08 01:48:29 EST
any progress?
Comment 6 Mike A. Harris 2001-12-22 04:07:57 EST
All releases of Red Hat Linux come with both XFree86 4.x, and 3.3.6.
4.x is the default for all hardware we believe to work best with it,
and 3.3.6 is used when hardware is known to be troublesome under 4.x.

You should first try running Xconfigurator and reconfiguring X.  If
that doesn't work, then try using "Xconfigurator --preferxf3" to force
it to use 3.3.6.

Does this help?
Comment 7 Need Real Name 2001-12-23 02:24:54 EST
As I said in my original comments, this was tried at the behest of tech support. Their last comments were:
>Usually the solution for lower RAM is to use the other mode or lower bit mode.  
 >If the issue still persists, we recommend posting it to bugzilla entry because 
 >we already tried various solutions such as using the lowest mode, using the old 
 >server, and others.  This can also be due to bug errors which our System 
 >Developers may assist you more.

But, in the interests of completeness I tried one more time.
Running Xconfigurator gives this for the probe: PCI entry: Matrox:mga 1064sg (mystique)
                                                                            X Server:  XF86_SVGA
                                                                           XFree 4 driver:  mga     (default)

Running Xconfigurator --preferxf3 gives the same thing except for XFree 4 driver:  (default). Hitting O.K. at this point gives: "Server doesn't exist, can't continue. Tried 
to use ../../usr/X11R6/bin/XF86_SVGA".

Either way it seems to detect XFree 4.x and not XFree 3.x. Running Xconfigurator with no option, I see no way to choose the X server. 

Man mga claims that the Mystique card gives no problems, nor are any mentioned in the RH site or any newsgroups that I can find. I continue to be snowed.
Comment 8 Mike A. Harris 2002-03-07 15:49:04 EST
It appears that the XFree86 3.3.6 server is not installed so X configurator
cannot find it to use it.  What does: rpm -q XFree86-SVGA report?
Comment 9 Need Real Name 2002-03-08 12:24:32 EST
rpm -q XFree86-SVGA  reports: XFree86-SVGA-3.3.6-42
Comment 10 Mike A. Harris 2002-09-05 08:08:55 EDT
This is fixed aparently in our latest rawhide release of XFree86 4.2.0,
since I'm unable to reproduce it.  Closing bug as fixed in RAWHIDE.

If you get a chance to test the latest rawhide, or perhaps wait for
our new distro release to upgrade to, and the problem persists, please
reopen the bug.

It seems fairly stable for me right now however.

Note You need to log in before you can comment on or make changes to this bug.