Bug 56798 - Internal compiler error in scan_region, at except.c:2809
Internal compiler error in scan_region, at except.c:2809
Status: CLOSED DUPLICATE of bug 48835
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2001-11-27 17:40 EST by Anand Krishnan
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:48:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Anand Krishnan 2001-11-27 17:40:51 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-12 i686)

Description of problem:
An internal compiler error occurs when trying to compile/build the TAO (the
ACE Orb) software package. It can be obtained thru the following URL:

Version-Release number of selected component (if applicable): g++-2.96-85

How reproducible:

Steps to Reproduce:
1. cd $TAO_ROOT/tao
2. make

Actual Results:  make[1]: Entering directory
g++ -W -Wall -Wpointer-arith -pipe -O3 -g -Wno-uninitialized
-D_REENTRANT -DACE_HAS_AIO_CALLS  -I/usr/local/ACE_wrappers
-DACE_HAS_EXCEPTIONS    -I/usr/local/ACE_wrappers/TAO  -c -fPIC -o
.shobj/PolicyS.o PolicyS.cpp
PolicyS.cpp: In function `void POA_CORBA_Policy::_get_policy_type_skel 
(TAO_ServerRequest &, void *, void *, Environment &)':
PolicyS.cpp:894: Internal compiler error in scan_region, at except.c:
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [.shobj/PolicyS.o] Error 2
make[1]: Leaving directory `/usr/local/ACE_wrappers/TAO/tao/PortableServer'

Expected Results:  A clean compile with an object file, PolicyS.o created.

Additional info:
Comment 1 Jakub Jelinek 2001-11-28 04:56:00 EST
This sounds like bug #48835. Can you please try gcc-c++-2.96-97 or later?
Comment 2 Jakub Jelinek 2004-10-02 15:50:49 EDT
No response in almost 3 years, closing.

*** This bug has been marked as a duplicate of 48835 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:48:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.