Bug 56819 - segfaults in perl -MCPAN -e 'install "Bundle::Bugzilla"'
Summary: segfaults in perl -MCPAN -e 'install "Bundle::Bugzilla"'
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-28 08:53 UTC by Zdravko Stoychev
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-12 00:19:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zdravko Stoychev 2001-11-28 08:53:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I'm using all standard settings in configuration process except gethostname
() [n]: yes
.....
`sh  cflags libperl.a op.o`  op.c
          CCCMD =  cc -DPERL_CORE -c -fno-strict-aliasing -
D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2
op.c: In function `S_new_logop':
op.c:3651: Internal error: Segmentation fault.
make: *** [op.o] Error 1
  /usr/bin/make  -- NOT OK

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. perl -MCPAN -e 'install "Bundle::Bugzilla"'
2.
3.
	

Actual Results:  op.c:3651: Internal error: Segmentation fault.

Additional info:

Comment 1 Chip Turner 2002-04-11 00:21:51 UTC
this probably should work with the 7.2 perl 5.6.1 errata; can you test in a 7.2
environment?

Comment 2 Zdravko Stoychev 2002-04-11 08:34:05 UTC
I've tested it on RedHat 7.2 system and:


t/dbi...............prepare() failed: Syntax error in select statement ("DROP 
TABLE usr")
Can't call method "execute" without a package or object reference at t/dbi.t 
line 134.

so one of the db tests failed. Should I skip them to continue?

Comment 3 Chip Turner 2002-04-12 00:19:27 UTC
sounds like the problem is now in the realm of your DBI/DBD::mysql settings (or
whatever DBD bugzilla uses) and no longer a perl bug, closing out.

as a suggestion, I'd check to make sure your database is working properly, and
maybe check the bugzilla site to see if it's a known error?


Note You need to log in before you can comment on or make changes to this bug.