This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 56821 - Please split Motif 1.2 and 2.1 runtimes into separate packages
Please split Motif 1.2 and 2.1 runtimes into separate packages
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: lesstif (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-28 04:43 EST by Toralf
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-28 04:43:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Toralf 2001-11-28 04:43:41 EST
Description of Problem:
libXm.so.1 and libXm.so.2 are included in the same package, i.e. you have
to install either both or none of them.

This is a problem because libXm.so.1 is required by a number of packages in
the OS distribution, while I have other applications that need libXm.so.2,
but won't work with lesstif (the interface drawn incorrectly) - they need
an alternative implementation, like openmotif (which has libXm.so.2 only.)

Version-Release number of selected component (if applicable):
0.92.32-6

Additional Information:
Somewhat related to Bug 56780
Comment 1 Ngo Than 2001-11-28 06:58:09 EST
The lesstif-0.93.15-1 won't include Lesstif-2.x. It does not make sense to
support it, because it lacks many functions. Many users should use openmptif-2.x
Comment 2 Toralf 2001-11-28 07:09:04 EST
Quite possibly what I was seeing when I tested my apps...

Shouldn't openmotif packages be included somewhere? I know they used to be in
Power Tools, but as far as I understand, there is no longer such a distribution.

I've also asked this question on "Red Hat ContribNet"...
Comment 3 Rex Dieter 2002-01-03 13:49:41 EST
FYI, lesstif-0.93.15-2 and openmotif-2.1.30-8 conflict:
> rpm -i openmotif-2.1.30-8.i386.rpm
file /usr/X11R6/bin/xmbind from install of openmotif-2.1.30-8 conflicts with 
file from package lesstif-0.93.15-2
file /usr/X11R6/man/man1/xmbind.1.gz from install of openmotif-2.1.30-8 
conflicts with file from package lesstif-0.93.15-2


Note You need to log in before you can comment on or make changes to this bug.