Bug 568248 - valpy_string nomem
Summary: valpy_string nomem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gdb
Version: 12
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jan Kratochvil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:88af23d592fcaf99017b7b7daf4...
: 589765 593703 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-25 06:39 UTC by Matteo Corti
Modified: 2010-08-06 16:58 UTC (History)
4 users (show)

Fixed In Version: gdb-7.1.90.20100806-8.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-06 16:58:42 UTC


Attachments (Terms of Use)
File: backtrace (25.73 KB, text/plain)
2010-02-25 06:39 UTC, Matteo Corti
no flags Details

Description Matteo Corti 2010-02-25 06:39:52 UTC
abrt 1.0.7 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: gdb -batch -ex 'set set debug-file-direc set debug-file-directory /usr/lib/debug:/var/ca' -ex 'file file /usr/bin/te' -ex 'core-file core-file /var/cache/abrt/ccpp-1267032127-2707' -ex 'thread threa thr thread ap thre thre' -ex 'info info shar' -ex 'print print (char*)__abo' -ex 'print print (char*)__glib_asse'
component: gdb
executable: /usr/bin/gdb
kernel: 2.6.31.12-174.2.22.fc12.i686
package: gdb-7.0.1-31.fc12
rating: 4
reason: Process /usr/bin/gdb was killed by signal 6 (SIGABRT)
release: Fedora release 12 (Constantine)

Comment 1 Matteo Corti 2010-02-25 06:39:54 UTC
Created attachment 396228 [details]
File: backtrace

Comment 2 Jan Kratochvil 2010-03-11 23:15:13 UTC
Guessing there could be an uninitialized string (being attempted to be pretty printed).

Comment 3 Karel Klíč 2010-05-25 09:32:26 UTC
*** Bug 589765 has been marked as a duplicate of this bug. ***

Comment 4 Karel Klíč 2010-05-25 09:32:31 UTC
*** Bug 593703 has been marked as a duplicate of this bug. ***

Comment 5 Jan Kratochvil 2010-06-01 16:49:12 UTC
Posted:
[rfc patch] nomem: internal_error -> error
http://sourceware.org/ml/gdb-patches/2010-06/msg00005.html

Comment 6 Jan Kratochvil 2010-08-06 16:58:42 UTC
It is not the right fix but it should work in most cases.
The right fix (in the second mail follow-up) is currently a too large project for this problem.


Note You need to log in before you can comment on or make changes to this bug.