Bug 56853 - print jobs refuse to print and give an error with mf_wrapper
print jobs refuse to print and give an error with mf_wrapper
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-28 15:52 EST by Adam Cowell
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-20 21:38:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of the printer queue (2.02 KB, text/plain)
2001-11-28 15:55 EST, Adam Cowell
no flags Details

  None (edit)
Description Adam Cowell 2001-11-28 15:52:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120

Description of problem:
When I try printing any type of file, including the postscript test and
the ascii test the job joins the print queue and comes up with an error
(in the KDE print queue proggy). which says something along the lines of.

Printer: hp1218@bertha
Queue: 1 printable job
Unspooler: pid2029 active
Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at
20:34:32.415

i have tried in the default kernel and in kernel 2.4.16. I run up2date
daily so have the latest printconf. Unfortunately I cannot remember if I
used the printer before up2date updated the printconf, but I think I
did, as i ran the postscript test when i setup the drivers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.open any file
2.tell the file to print
3.watch the status and the error appears and the print job disappears
	

Actual Results:  the file never printed and the error which is mentioned
above was shown

Expected Results:  should of had a nice print out of something

Additional info:

I am not completely sure if lpd keeps a log of errors, but i am
attaching a file i think might help as it seems to be a log.
Comment 1 Adam Cowell 2001-11-28 15:55:07 EST
Created attachment 38984 [details]
log of the printer queue
Comment 2 Tim Waugh 2002-01-10 08:35:19 EST
What model of printer is this?  Does this work (as root)?:

cat /etc/fstab > /dev/lp0

(I'm assuming this is a parallel port printer plugged into the motherboard's 
builtin port.)

Could you attach /etc/alchemist/namespace/printconf/local.adl please?
Comment 3 Adam Cowell 2002-01-20 21:38:35 EST
The printer is a HP Photosmart 1218 connected via the USB port. The printer did
suddenly started working in Linux again a week later. And had no problems since.

Not attached the requested file as i suspect it would be of no benefit now the
printer seems to be working agian.
Comment 4 Tim Waugh 2002-01-21 08:50:50 EST
Okay, closing.  Wonder what that was about.

Note You need to log in before you can comment on or make changes to this bug.