Bug 56854 - edit density for stp driver causes traceback
edit density for stp driver causes traceback
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-28 16:52 EST by Ben Levenson
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 12:27:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2001-11-28 16:52:56 EST
Description of Problem:
Received a traceback while editing the *1st* density setting for the stp
driver (HP Laserjet 6).

This only occurs w/ printconf-tui. I had no problems while running
printconf-gui. 

  <snip>
  Page Size
  REt Setting
  Density     <-- edit this for traceback
  Contrast Level
  StpBrightness
  MP Tray
  Density     <-- no probles here, except for the fact that the options
                  appear to be out of order: 4, 5, 3, 2, 1

Version-Release number of selected component (if applicable):
printconf-0.3.52-1
foomatic-1.1-0.20011018.6

How Reproducible:
100%

Steps to Reproduce:
1. printconf-tui
2. configure lp-devel w/ stp driver
3. edit *1st* density setting under driver options

Actual Results:
printconf-tui exits w/ the following traceback:
Traceback (innermost last):
  File "/usr/sbin/printconf-tui", line 8, in ?
      printconf_tui.startup_and_find_cmd()
        File "/usr/share/printconf/util/printconf_tui.py", line 2174,
in startup_and_find_cmd
    main.cmd_handlers[cmd]()
      File "/usr/share/printconf/util/printconf_tui.py", line 2053, in
tui_main_run
    qld_run()
      File "/usr/share/printconf/util/printconf_tui.py", line 1949, in
qld_run
    qed_run(queue_dict)
      File "/usr/share/printconf/util/printconf_tui.py", line 842, in
qed_run
    qed_ded_run()
      File "/usr/share/printconf/util/printconf_tui.py", line 1466, in
qed_ded_run
    qed_ded_eod_run()
      File "/usr/share/printconf/util/printconf_tui.py", line 1629, in
qed_ded_eod_run
    apply(funcs[option_list[index][0]], option_list[index][1:])
      File "/usr/share/printconf/util/printconf_tui.py", line 1663, in
qed_ded_eod_int_editor
    i_defval = int(defval)
    ValueError: invalid literal for int(): 1.0

Additional Information:
discovered while testing on s/390. reproduced on i686 w/ same version
of printconf and foomatic-1.1-0.20011018.7
Comment 1 Tim Waugh 2002-03-06 08:49:08 EST
Can't reproduce with printconf in rawhide.

Note You need to log in before you can comment on or make changes to this bug.