Bug 56868 - Sound stops working
Sound stops working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdemultimedia (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-29 02:50 EST by Neil Darlow
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 09:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Darlow 2001-11-29 02:50:07 EST
Description of Problem:
At logout the KDE exit sound isn't always played

Version-Release number of selected component (if applicable):


How Reproducible:
variable

Steps to Reproduce:
1. Just run KDE for several hours
2. 
3. 

Actual Results:
The sounds within KDE stop. First noticed when exit sound didn't play.
I get a lot of these in /var/log/messages:
Nov 28 21:07:11 ideal modprobe: modprobe: Can't locate module sound-slot-1
Nov 28 21:07:12 ideal modprobe: modprobe: Can't locate module 
sound-service-1-0
Nov 28 21:07:12 ideal modprobe: modprobe: Can't locate module sound-slot-1
Nov 28 21:07:12 ideal modprobe: modprobe: Can't locate module 
sound-service-1-0

Expected Results:


Additional Information:
kernel-2.4.9-13
SoundBlaster16 ISA PnP card configured manually with sndconfig
/etc/modules.conf:
alias sound-slot-0 sb
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L 
>/dev/null 2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 
2>&1 || :
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options sb isapnp=1
Comment 1 Steve Auerbach 2002-07-24 14:29:11 EDT
I have what appears to be the same problem with kernel  
2.4.18-5. I can cure the problem by the following steps:  
1 - kill the artsd daemon  
2 - restart the artsd daemon 
Sometimes this works, but sometimes I have to also use 
Panel:Sound Server to restart the sound server (by, for 
example, clicking on "Defaults", then on "Test Sound" 
I have a sound card from Turtle Beach. 
Info from sndconfig is:   
Model: Cirrus LogicICS 
4614/22/24 [CrystalClear SoundFusion Audio Accelerator].   
Comment 2 Ngo Than 2004-09-29 09:05:54 EDT
i cannot reproduce this problem in fc2 and fc3test2. it's fixed in
current release.

Note You need to log in before you can comment on or make changes to this bug.