Bug 568692 - Search started in wrong directory due to reversed true/false clauses in if()
Summary: Search started in wrong directory due to reversed true/false clauses in if()
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-search-tool
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Paul W. Frields
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-02-26 11:33 UTC by James
Modified: 2010-03-10 06:42 UTC (History)
1 user (show)

Fixed In Version: nautilus-search-tool-0.3.0-7.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-09 03:34:44 UTC
Type: ---


Attachments (Terms of Use)
Patch to reverse order of true/false clauses in affected if (572 bytes, patch)
2010-02-26 11:33 UTC, James
no flags Details | Diff

Description James 2010-02-26 11:33:12 UTC
Created attachment 396518 [details]
Patch to reverse order of true/false clauses in affected if

The if() at around line 103 in nautilus-search-tool.c seems to be the wrong way around. As shipped, it supplies gnome-search-tool with no arguments if g-s-t's version is >= 2.22; surely if this is the case, we want to pass the "--path=" argument? Otherwise, g-s-t starts the search from the last directory it was given, rather than that of the context of the Nautilus menu option by which it was invoked.

Comment 1 Paul W. Frields 2010-02-27 02:25:06 UTC
Holy moley, I can't believe how long I've stared at that plugin code without seeing this.  Thanks for this patch, I'll make sure it goes upstream too.

Comment 2 Paul W. Frields 2010-02-27 02:48:35 UTC
Built and tested here, looks great.  I'm building now for F-12 and beyond, updates on the way soon.

Comment 3 Fedora Update System 2010-02-27 04:00:21 UTC
nautilus-search-tool-0.3.0-7.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/nautilus-search-tool-0.3.0-7.fc13

Comment 4 Fedora Update System 2010-02-27 04:01:33 UTC
nautilus-search-tool-0.3.0-6.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/nautilus-search-tool-0.3.0-6.fc12

Comment 5 Paul W. Frields 2010-02-27 04:03:33 UTC
James, if you could help me by testing any of the updates, I'd appreciate it.  The F-12 package is here:

http://koji.fedoraproject.org/koji/buildinfo?buildID=158894

After you update and test it, give it some karma here:

https://admin.fedoraproject.org/updates/nautilus-search-tool-0.3.0-6.fc12

The sooner I get some testing the sooner I can push it out to stable.  Thanks!

Comment 6 James 2010-02-27 08:38:47 UTC
(In reply to comment #5)
> James, if you could help me by testing any of the updates, I'd appreciate it. 
> The F-12 package is here:

Updated, it seems to work as intended for me (for legit FS targets, reverts to home directory on things like the Wastebin; but then again, these things don't show up as start-points in g-s-t anyway. Suggest removal from context menu for these later?).

Comment 7 Fedora Update System 2010-02-27 13:00:00 UTC
nautilus-search-tool-0.3.0-7.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nautilus-search-tool'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F13/FEDORA-2010-3110

Comment 8 Fedora Update System 2010-03-02 01:08:26 UTC
nautilus-search-tool-0.3.0-6.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nautilus-search-tool'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-3311

Comment 9 Fedora Update System 2010-03-09 03:34:40 UTC
nautilus-search-tool-0.3.0-6.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2010-03-10 06:42:11 UTC
nautilus-search-tool-0.3.0-7.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.