Bug 568775 - libguestfs-tools has missing dependency on perl-XML-Writer
libguestfs-tools has missing dependency on perl-XML-Writer
Status: CLOSED DUPLICATE of bug 562858
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-26 10:42 EST by Mikolaj Kucharski
Modified: 2010-02-26 11:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-26 11:13:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Kucharski 2010-02-26 10:42:08 EST
# virt-df
Can't locate XML/Writer.pm in @INC (@INC contains: /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.10.0/i386-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl .) at /usr/bin/virt-df line 30.
BEGIN failed--compilation aborted at /usr/bin/virt-df line 30.


# find /usr/ | grep XML/Writer.pm
# yum install perl-XML-Writer


# virt-df
Filesystem                           1K-blocks       Used  Available  Use%
ocurrent1:/dev/sda5                    3603762     667394    2756188 23.5%
fedora12:/dev/sda1                     3094964    1005540    1932208 37.6%


# rpm -qf `which virt-df`
libguestfs-tools-1.0.81-1.fc12.4.i686
Comment 1 Richard W.M. Jones 2010-02-26 11:13:43 EST
I think we fixed this already.  Try the package
Fedora 12 updates, which has added this dependency.

*** This bug has been marked as a duplicate of bug 562858 ***

Note You need to log in before you can comment on or make changes to this bug.