This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 569354 - Squid reports 411 with PUT/POST request without Content-Length
Squid reports 411 with PUT/POST request without Content-Length
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: squid (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Pavel Šimerda (pavlix)
BaseOS QE - Apps
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-01 07:15 EST by Simon Matter
Modified: 2014-02-12 10:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-12 10:36:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Allow PUT/POST without Content-Length (483 bytes, patch)
2010-03-01 07:15 EST, Simon Matter
no flags Details | Diff

  None (edit)
Description Simon Matter 2010-03-01 07:15:28 EST
Created attachment 397048 [details]
Allow PUT/POST without Content-Length

Description of problem:
Squid doesn't work for websites which do PUT/POST requests without Content-Length header. It replies with a TCP_DENIED/411 instead of processing the request which seems to be perfectly valid.

Version-Release number of selected component (if applicable):
squid-2.6.STABLE21-3.el5

How reproducible:
Let you browser do such a request.
  
Actual results:
TCP_DENIED/411 2392 POST http://mainoffice.xxxxx.de/intern/modules/logon/session_refresh.php? - NONE/- text/html

Expected results:
TCP_MISS/200 815 POST http://mainoffice.xxxxx.de/intern/modules/logon/session_refresh.php? - DIRECT/xx.xxx.xx.xxx text/html

Additional info:
The bug is fixed in upstream squid-2.6.STABLE23.

The fix below with attached patch fixes it for me.

Note: The same patch also fixes it for RHEL4.

--- squid-2.6.STABLE21-3.el5.src/squid.spec     2008-09-09 14:34:21.000000000 +0200
+++ squid-2.6.STABLE21-3.el5.invoca1.src/squid.spec     2010-03-01 12:20:43.000000000 +0100
@@ -5,7 +7,7 @@
 Summary: The Squid proxy caching server.
 Name: squid
 Version: 2.6.STABLE21
-Release: 3%{?dist}
+Release: 3%{?dist}.invoca1
 Epoch: 7
 License: GPL
 Group: System Environment/Daemons
@@ -32,6 +34,7 @@
 Patch205: squid-2.6.STABLE21-fd-config.patch
 Patch206: squid-2.6.STABLE21-config.patch
 Patch207: squid-2.6.STABLE21-chk_unix_group.patch
+Patch1000: squid-2.6.STABLE23-post_content-length.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Prereq: /sbin/chkconfig logrotate shadow-utils
@@ -63,6 +66,7 @@
 %patch205 -p1 -b .fd-config
 %patch206 -p1 -b .config
 %patch207 -p1 -b .chk_unix_group
+%patch1000 -p1 -b .post_content-length
 
 %build
  export CFLAGS="-D_FORTIFY_SOURCE=2 -fPIE -Os -g -pipe -fsigned-char" ; export LDFLAGS=-pie ;
@@ -327,6 +331,9 @@
     chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
 
 %changelog
+* Mon Mar 01 2010 Simon Matter <simon.matter@invoca.ch> 7:2.6.STABLE21-3.invoca1
+- allow missing content-length with PUT/POST request
+
 * Wed Sep 03 2008 Jiri Skala <jskala@redhat.com> 7:2.6.STABLE21-3
 - Resolves: #245304 optimizing init script
Comment 3 RHEL Product and Program Management 2010-08-09 14:24:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2011-01-11 15:33:30 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2011-01-12 10:10:33 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 6 RHEL Product and Program Management 2011-05-31 09:26:11 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 Pavel Šimerda (pavlix) 2014-02-12 10:36:26 EST
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification. Issue is already fixed in RHEL-6/7.

Note You need to log in before you can comment on or make changes to this bug.