Bug 56942 - kernel 2.4.9-13 upgrade causes extra scsi module to load causing Oops!
kernel 2.4.9-13 upgrade causes extra scsi module to load causing Oops!
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-30 14:10 EST by Corey MJ Wirun
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 19:03:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey MJ Wirun 2001-11-30 14:10:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; T312461)

Description of problem:
With a non-modified, base 7.2 system (kernel 2.4.7-10), I used up2date to 
upgrade the kernel and kernel headers to 2.4.9-13.  When the system 
rebooted and I selected the new kernel in GRUB, the AM53C974 driver loads, 
I see all my scsi devices dumped, and it then tries to load the tmscsim 
module, and the kernel panics.  The old kernel did not load tmscsim after 
the AM53C974 scsi driver.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot
2.
3.
	

Actual Results:  The tmscsim driver should not be loading after the 
AM53C974.

Additional info:

When I originally installed the base 7.2 OS, I had problems with the same 
kernel panic when the install would go to run Disk Druid.  I reported a 
bug #56546.  The tech responded that I should install with 'linux noprobe' 
to override driver selections.  The install worked fine from that point on.

It looks like the same autodetect is happening.  Can I disable this 
loading of tmscsim again somehow?
Comment 1 Corey MJ Wirun 2001-12-06 16:03:15 EST
(Is there any work on this problem?)

Would the recent up2date issues with kernel upgrades somehow be affecting me 
here?



Comment 2 Arjan van de Ven 2001-12-06 16:06:18 EST
Can you check /etc/modules.conf to see if that driver is in there ?
Comment 3 Corey MJ Wirun 2001-12-06 16:26:40 EST
If the driver was in there, wouldn't it have attempted to load when booting the 
old 2.4.7 kernel?  When the old kernel boots, I don't see any msg saying 
tmscsim is being loaded.  That's what I don't understand - why does tmscsim 
attempt to load with the new 2.4.9 kernel?

I have three scsi-relevant lines in the modules.conf file:

...
alias scsi_hostadapter AM53C974
alias scsi_hostadapter1 null
alias tmscsim null

I put the nulls in thinking it would prevent the tmscsim modules from loading.

Thanks!
Comment 4 Arjan van de Ven 2001-12-06 16:33:15 EST
There's one caveat here. If you did this AFTER you installed the 2.4.9 kernel,
the initrd already will load the driver (think about it: the initrd is the thing
used to load the scsi drivers in the kernel, it needs that before it can read
the file) so you'll have to recreate that.

Easy to do:

mv /boot/initrd-2.4.9-13.img /boot/initrd-2.4.9-13.img.backup
mkinitrd /boot/initrd-2.4.9-13.img 2.4.19-13

(replace "13" with "13smp" if you have the smp kernel)

Note You need to log in before you can comment on or make changes to this bug.