Bug 56999 - locate does not return correct results.
Summary: locate does not return correct results.
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: slocate   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-12-02 21:32 UTC by Edward Rudd
Modified: 2007-04-18 16:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-15 18:45:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Edward Rudd 2001-12-02 21:32:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
using locate to find files as root returns "odd" results. and running as a
normal user returns incomplete or no results.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rm /var/lib/slocate/slocate.db
2./etc/crond.daily/updatedb (as root, su -)
3.locate Xpm
	

Actual Results:  as Root.
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shopt/kylix/lib/Xpm.dcu
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shopt/kylix/lib/Xpm.dpu
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shopt/kylix/source/rtl/linux/Xpm.pas
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/X11R6/include/Xm/XpmP.h
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/X11R6/lib/libXpm.so.4
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/X11R6/lib/libXpm.so.4.11
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/X11R6/lib/libXpm.a
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/X11R6/lib/libXpm.so
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/lib/perl5/site_perl/5.6.0/i386-linux/Tk/pTk/tixImgXpm_f.h
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/lib/perl5/site_perl/5.6.0/i386-linux/Tk/pTk/tixImgXpm.h
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/lib/perl5/site_perl/5.6.0/i386-linux/Tk/pTk/tixImgXpm.m
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/lib/perl5/site_perl/5.6.0/i386-linux/Tk/pTk/tixImgXpm.t
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/lib/linuxconf/java/XpmParser.class
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/lib/tix4.1/demos/samples/Xpm.tcl
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/lib/tix4.1/demos/samples/Xpm1.tcl
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/i486-linux-libc5/lib/libXpm.so.4.9
/home/urkle/.gnome.kde/shamp3/g_schi.kde2/shusr/i486-linux-libc5/lib/libXpm.so.4
nothing as user Urkle.

Expected Results:  /opt/kylix/lib/Xpm.dcu
/opt/kylix/lib/Xpm.dpu
/opt/kylix/source/rtl/linux/Xpm.pas
/usr/X11R6/include/Xm/XpmP.h
/usr/X11R6/lib/libXpm.so.4
/usr/X11R6/lib/libXpm.so.4.11
/usr/X11R6/lib/libXpm.a
/usr/X11R6/lib/libXpm.so
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Tk/pTk/tixImgXpm_f.h
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Tk/pTk/tixImgXpm.h
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Tk/pTk/tixImgXpm.m
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Tk/pTk/tixImgXpm.t
/usr/lib/linuxconf/java/XpmParser.class
/usr/lib/tix4.1/demos/samples/Xpm.tcl
/usr/lib/tix4.1/demos/samples/Xpm1.tcl
/usr/i486-linux-libc5/lib/libXpm.so.4.9
/usr/i486-linux-libc5/lib/libXpm.so.4


Additional info:

when running a search as Urkle for a file in urkle's home directory. will
return no results for most queries.

Things work find on my RH6.2 system.  Though this bug has been annoying me
for a while. (on RH 6.x and 7.x systems)

Comment 1 Thomas Woerner 2004-10-15 18:45:58 UTC
Please verify this with a newer version of Red Hat Enterprise Linux or
Fedora Core and reopen it against the new version if it still occurs.

Closing as "not a bug" for now.



Note You need to log in before you can comment on or make changes to this bug.