Bug 570086 - rpmlint doesn't correctly process ghosted pam files
rpmlint doesn't correctly process ghosted pam files
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-03 04:02 EST by Jaroslav Škarvada
Modified: 2011-10-12 07:43 EDT (History)
4 users (show)

See Also:
Fixed In Version: rpmlint-0.95-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-03 13:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ignore ghost files in pam check (715 bytes, patch)
2010-03-03 04:02 EST, Jaroslav Škarvada
no flags Details | Diff

  None (edit)
Description Jaroslav Škarvada 2010-03-03 04:02:44 EST
Created attachment 397511 [details]
Ignore ghost files in pam check

Description of problem:
rpmlint tries to open and pamcheck ghosted pam files that ends up with strange error. I encounter this on sendmail-8.14.4-4.fc14.

Version-Release number of selected component (if applicable):
rpmlint-0.94-1.fc14

How reproducible:
always

Steps to Reproduce:
1. ghost any pam file from /etc/pam.d/ in spec (e.g. foo)
2. run rpmlint on resulting rpm

Actual results:
W: read-error /etc/pam.d/foo [Errno 2] No such file or directory:

Expected results:
No warning

Additional info:
Looks like there is missing check in PamCheck.py for ghost files, something like the code in the included patch should resolve the problem.
Comment 1 Ville Skyttä 2010-03-03 13:18:39 EST
Thanks, done in AbstractFilesCheck level upstream so it applies to more cases:
http://rpmlint.zarb.org/cgi-bin/trac.cgi/changeset/1735

0.95 containing this fix will be available shortly.
Comment 2 Fedora Update System 2010-03-06 15:15:07 EST
rpmlint-0.95-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/rpmlint-0.95-2.fc13
Comment 3 Fedora Update System 2010-03-06 15:16:24 EST
rpmlint-0.95-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/rpmlint-0.95-2.fc12
Comment 4 Fedora Update System 2010-03-11 08:31:23 EST
rpmlint-0.95-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2010-03-11 23:28:08 EST
rpmlint-0.95-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.