Bug 57028 - kmail crashes when fetching POP e-mail
kmail crashes when fetching POP e-mail
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdenetwork (Show other bugs)
7.2
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-03 11:36 EST by Need Real Name
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 06:30:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-12-03 11:36:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Win95; U)

Description of problem:
When kmail is told to download e-mail it does so, but then crashes with 
signal 8 (SIGFPE).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Connect via PPP (kppp) to ISP (attglobal.net or nocharge.com)
2. Bring up kmail.
3. Click on "download e-mail" button.
	

Actual Results:   Kmail reports "preparing connection to 
pop4.attglobal.net" for tens of seconds, sometimes switching an e-mail 
address in the bottom bar (and I can see the e-mails appear in the 
right-hand pane), then it reports a crash -- signal 8 (SIGFPE).   The 
e-mails that come in are rather short, several dozens of lines of text (and 
they remain on the server machine.) The same failure occurs with two 
different accounts (but both on attglobal.net.)

Expected Results:  It should have downloaded e-mail and then let me read 
it, without crashing. :-)


Additional info:

I connect to my ISP, bring up kmail and click on the button to 

I reported the bug to KDE.   http://bugs.kde.org/db/35/35642.html
But the reply from Marc Mutz (mailto:mutz@kde.org) is:
  "Tell Redhat not to use objprelink in their RPM's. It's buggy."

Report included the following data:

(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x411a8999 in __wait4 () from /lib/libc.so.6
#0  0x411a8999 in __wait4 () from /lib/libc.so.6
#1  0x41224c90 in __DTOR_END__ () from /lib/libc.so.6
#2  0x40972838 in KCrash::defaultCrashHandler () at eval.c:41
#3  <signal handler called>
#4  0x08174462 in KDialog::marginHint () at eval.c:41
#5  0x000005a3 in ?? () at eval.c:41
#6  0x404b91f3 in KIO::TransferJob::data () at eval.c:41
#7  0x404fe3d5 in KIO::TransferJob::slotData () at eval.c:41
#8  0x4048c4d2 in KIO::SlaveInterface::data () at eval.c:41
#9  0x404883dd in KIO::SlaveInterface::dispatch () at eval.c:41
#10 0x404fccc1 in KIO::SlaveInterface::dispatch () at eval.c:41
#11 0x40486f94 in KIO::Slave::gotInput () at eval.c:41
#12 0x40c20c81 in QObject::activate_signal ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#13 0x40c75a76 in QSocketNotifier::activated ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#14 0x40c53f67 in QSocketNotifier::event ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#15 0x40bd0891 in QApplication::notify () from 
/usr/lib/qt-2.3.1/lib/libqt.so.2
#16 0x408d9c89 in KApplication::notify () at eval.c:41
#17 0x40b9b12b in sn_activate () from /usr/lib/qt-2.3.1/lib/libqt.so.2
#18 0x40b9b999 in QApplication::processNextEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#19 0x40bd274c in QApplication::enter_loop ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#20 0x40b9b197 in QApplication::exec () from 
/usr/lib/qt-2.3.1/lib/libqt.so.2
#21 0x0817c950 in KDialog::marginHint () at eval.c:41
#22 0x411111f6 in __libc_start_main (
    main=0x817c440 <KDialog::marginHint(void)+1113056>, argc=7, 
    ubp_av=0xbffffbf4, init=0x8065828 <_init>, fini=0x81b89f0 <_fini>,
    rtld_fini=0x4000cfe8 <_dl_fini>, stack_end=0xbffffbec)
    at ../sysdeps/generic/libc-start.c:129


(Severity set to "High" because it's a crash.  In terms of value of RH7.2 
to me, personally, it's also high though I realize others' mileage may 
vary.)
Comment 1 Ngo Than 2004-07-28 06:30:41 EDT
it's not reproduceable in current release.

Note You need to log in before you can comment on or make changes to this bug.