Bug 570511 - ls DIR_COLORS is too dark
ls DIR_COLORS is too dark
Status: CLOSED DUPLICATE of bug 496402
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2010-03-04 10:35 EST by Don Hoover
Modified: 2010-03-10 03:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-03-10 03:37:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Don Hoover 2010-03-04 10:35:38 EST
Description of problem:
Can't we get some agreement that maybe the default ls colors could use some tweaking?  I get 1.5 MILLION results in google when I search for how to fix this.  

Even on a physical tty console, the color blue used for directories is too dark.

Can we change it to emphasized blue for the default?

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Kamil Dudka 2010-03-04 10:42:40 EST
It looks like bug 239501 to me.  The key problem is that terminals have either light or dark background.  The current situation among them does not allow to detect the background color reliably, and there are no optimal colors which work well on any background.
Comment 2 Don Hoover 2010-03-04 10:48:48 EST
Yes, but should'nt the default colors at lest work on physical consoles?  If someone wants to have a light terminal they are more than welcome to tweak their colors in their profile. But right now a huge number of people who don't use any custom terminal sessions are having to customize these colors so they are readable on the defaults of nearly every terminal program and physical console out there.
Comment 3 Ondrej Vasik 2010-03-04 10:51:29 EST
As Kamil already said, there is no optimal blue for dark/light background. We ship three predefined color sets - one for lightbackground, one for dark background (the same as is used by upstream and default) and one for 256-colors terminals. If you have some idea for color set which would match the current coloring scheme and will work correctly on dark and light background, feel free to propose it. 

Otherwise it is just another bz about the same thing - one currently opened is one aginst F-11 - https://bugzilla.redhat.com/show_bug.cgi?id=496402 .
Comment 4 Ondrej Vasik 2010-03-10 03:37:00 EST
I'll close that DUPLICATE of #496402.

*** This bug has been marked as a duplicate of bug 496402 ***

Note You need to log in before you can comment on or make changes to this bug.