Bug 57052 - 7.2 install fails due to apparent anaconda problem
7.2 install fails due to apparent anaconda problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-03 15:26 EST by Wes Bethel
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-04 11:12:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anadonda dump file (60.77 KB, text/plain)
2001-12-03 15:27 EST, Wes Bethel
no flags Details

  None (edit)
Description Wes Bethel 2001-12-03 15:26:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
Both full 7.2 install as well as upgrade to 7.2 from 7.1 fail at the point
when it is time to actually start pulling in RPMs from the CD (not a
network install). The error box that popped up indicated this was an
anaconda problem and to file a bug report.

A quick perusal of existing 7.2 anaconda problems shows several
similar-sounding issues. Other reports failure points during install that
appear to be somewhat different from the one I'm experiencing.

At this point, we're unable to install or upgrade to 7.2.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Fresh 7.2 workstation install, or 7.2 workstation upgrade from 7.1.	

Actual Results:  Info collected by installer. After disk formatting,
install aborts reporting an anaconda error. Pls see attached dump.

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 350, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 778, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/usr/lib/anaconda/gui.py", line 399, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 273, in upgradeFindPackages
    method.mergeFullHeaders(id.hdList)
  File "/usr/lib/anaconda/image.py", line 26, in mergeFullHeaders
    hdlist.mergeFullHeaders(self.tree + "/RedHat/base/hdlist2")
  File "/usr/lib/anaconda/comps.py", line 161, in mergeFullHeaders
    rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
rpm.error: match tag missing in new header
Comment 1 Wes Bethel 2001-12-03 15:27:10 EST
Created attachment 39487 [details]
anadonda dump file
Comment 2 Brent Fox 2001-12-03 20:29:15 EST
Did you download the ISO images or did you buy the retail box set?  If you
downloaded the ISOs, did you check the md5sum of the ISO images before you
burned them to cd?  It looks like you could have bad cds.
Comment 3 Wes Bethel 2001-12-04 11:12:22 EST
This install was performed with copies of retail CDs. We will reattempt with the original retail CDs, and post results.
Comment 4 Wes Bethel 2001-12-11 11:29:55 EST
Follow-up info: using a fresh set of retail CD's, the 7.2 install/upgrade went smoothly, and with no problems.

We'll conclude that the copies of retail CD's we tried previously were somehow corrupted.

Thanks for the help!

Note You need to log in before you can comment on or make changes to this bug.