Bug 570808 - Cannot attach floppy disk image to domain, libVirtError
Cannot attach floppy disk image to domain, libVirtError
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-05 08:38 EST by Tim Waugh
Modified: 2010-05-10 16:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-10 16:17:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2010-03-05 08:38:48 EST
Description of problem:
My domain is shut off, and I want to add a floppy disk drive to it from a .img file.  I can't because of a libVirtError.

Version-Release number of selected component (if applicable):
libvirt-0.7.6-1.fc13.x86_64
qemu-kvm-0.12.3-3.fc13.x86_64
virt-manager-0.8.3-1.fc13.noarch

How reproducible:
100%

Steps to Reproduce:
1.Click 'Add Hardware'
2.Type is 'Storage'
3.Choose disk image file
4.Choose 'Floppy disk' as the device type
5.'Floppy 1' is added.  Now start the domain.

Actual results:
Error starting domain: internal error unable to start guest: can't parse: "isa-fdc,driveA=drive-fdc0-0-0"

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/engine.py", line 589, in run_domain
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1208, in startup
    self._backend.create()
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 300, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error unable to start guest: can't parse: "isa-fdc,driveA=drive-fdc0-0-0"
Comment 1 Cole Robinson 2010-03-05 11:12:26 EST
Fixed upstream by this commit, will be an easy backport:

http://libvirt.org/git/?p=libvirt.git;a=commit;h=9f013d5779610dc6d990b074c48329a21dd4a941
Comment 2 Cole Robinson 2010-03-23 14:38:46 EDT
This should be fixed by libvirt 0.7.7 in F-13 updates-testing.
Comment 3 Tim Waugh 2010-03-24 14:28:18 EDT
Yes, now boots.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.