Bug 571025 - 'Add/Remove Software' reports "There are unfinished transactions remaining. Please run yum-complete-transaction as root." even after running the stated command.
'Add/Remove Software' reports "There are unfinished transactions remaining. P...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-06 07:53 EST by storri
Modified: 2014-01-21 18:13 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-23 06:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description storri 2010-03-06 07:53:09 EST
Description of problem: Package reports in 'Add/Remove Software' that there is an internal error (reported below). The problem is coupled with another message window stating "There are unfinished transactions remaining. Please run yum-complete-transaction as root.". I did run yum-complete-transaction (results below). The first time cleared up a bunch of packages. Now I thought the problem would be resolved. I was wrong. I am not quite sure why this is happening. Only thing I can reason is that some file used by 'Add/Remove Software' to control its updating so it does not try it at the same time as another software updater (e.g. yum) is running. It looks to me like a state file or attribute is in a corrupted state. 

[root@master storri]# yum-complete-transaction
Loaded plugins: presto, refresh-packagekit
No unfinished transactions left.


Version-Release number of selected component (if applicable): gnome-packagekit-2.28.3-0.1.20091211git.fc12.x86_64


How reproducible:


Steps to Reproduce:
1. Start 'Add/Remove Software'
(Error appears)

 
Actual results:
Error Type: <class 'packagekit.backend.PkError'>
Error Value: 'failed-initialization: There are unfinished transactions remaining. Please run yum-complete-transaction as root.'
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3235, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3232, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 699, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 569, in dispatch_command
    self.get_repo_list(filters)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2451, in get_repo_list
    self._check_init()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2795, in _check_init
    raise PkError(ERROR_FAILED_INITIALIZATION, 'There are unfinished transactions remaining. Please run yum-complete-transaction as root.')


Expected results: Application to run and allow me to add applications


Additional info:
Comment 1 Douglas Furlong 2010-03-20 07:40:53 EDT
I am having a similar issue on my fathers system.

This issue was there for some time before I could look in to it. When I was able to run yum-complete-transactions I believe it could not complete when I arrived as the updates online had subsequently been further updated, and as such it was not able to use the packages it thought it should be using.

I ran yum upgrade manually, and upgraded to the latest versions, re-ran yum-complete transactions, and it succesuflly ran saying zyz package (about 60 of them) were all the latest version.

Howerver of subsequent runs of the Add/Remove software app, I still get the error.

Additinoally if I run the yum install command at the terminal, it also warns about unfinished transactions.

However yum-complete-transactions believes every thing is fine. I've also tried yum-complete-transactions --cleanup-only, yum clean all, package-cleanup --dupes, package-cleanup --problems

Any thoughts?
Comment 2 Douglas Furlong 2010-03-20 07:43:11 EDT
FYI I believe this is unrelated to gnome-packagekit and is actually related to yum, as stated, this error/warning occurs on the command line when using YUM directly.
Comment 3 Richard Hughes 2010-03-23 06:16:42 EDT
I'm pretty sure we've now fixed this in F12. Please re-open if you can still reproduce with a fully updated system. Thanks.
Comment 4 Douglas Furlong 2010-03-23 06:46:48 EDT
Good morning Richard

Unfortunately it's a bit cumbersome for me to test this as it's on my fathers PC, and a good old treck to get there.

Just to confirm, as of last Saturday (20th), the system was fully updated and I was experiencing the problem still.

Was I right in saying that the issue is related to yum as opposed gnome-packagekit, as yum was reporting the transaction error, and using the complete transactions script would not get rid of that error.
Comment 5 Richard Hughes 2010-03-23 07:06:11 EDT
(In reply to comment #4)
> Was I right in saying that the issue is related to yum as opposed
> gnome-packagekit, as yum was reporting the transaction error, and using the
> complete transactions script would not get rid of that error.    

Cool, I'll reassign to that component then. Thanks.
Comment 6 seth vidal 2010-03-23 09:04:20 EDT
Douglas,
 what version of yum and yum-utils are you using?
Comment 7 storri 2010-03-23 14:24:56 EDT
yum: yum-3.2.25-1.fc12.noarch
yum-utils: yum-utils-1.1.26-1.fc12.noarch

Note You need to log in before you can comment on or make changes to this bug.