Bug 57107 - problems compiling new kernel with AMD AthlonXP 1600+
problems compiling new kernel with AMD AthlonXP 1600+
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
other Linux
high Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-12-04 17:58 EST by pantelis
Modified: 2007-03-26 23:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-08 15:49:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pantelis 2001-12-04 17:58:45 EST
Description of Problem:
Hello.
I 've upgraded my pc , from a P II 350Mhz to AMD AthlonXP 1600+.
I 've re-installed RedHat linux from scratch and now with the new 
processor I can't compile a new kernel
here are the errors I get:


gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes -O2 
-fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=athlon   -DUTS_MACHINE='"i386"' -c -o
init/version.o init/version.c
make CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing
-fno-common -Wno-unused -pipe -mpreferred-stack-boundary=2 -march=athlon  "
-C  kernel
make[1]: Entering directory `/usr/src/linux-2.4.2/kernel'
make all_targets
make[2]: Entering directory `/usr/src/linux-2.4.2/kernel'
gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=athlon     -DEXPORT_SYMTAB -c ksyms.c
ksyms.c:201: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [ksyms.o] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.2/kernel'
make[1]: *** [first_rule] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.2/kernel'
make: *** [_dir_kernel] Error 2


As you can see it starts compiling and then I get these errors

Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Arjan van de Ven 2001-12-05 04:13:14 EST
Is it every time in ksyms.c ?
Comment 2 pantelis 2001-12-06 12:38:19 EST
hi this is panfe11@yahoo.com....
No it is not always on the ksysms.c file.
I tried again to compile the same kernel configuration and here is the output :


gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=athlon   -DUTS_MACHINE='"i386"' -c -o
init/version.o init/version.c
make CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes
-O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=athlon  " -C  kernel
make[1]: Entering directory `/usr/src/linux-2.4.2/kernel'
make all_targets
make[2]: Entering directory `/usr/src/linux-2.4.2/kernel'
make[2]: Nothing to be done for `all_targets'.
make[2]: Leaving directory `/usr/src/linux-2.4.2/kernel'
make[1]: Leaving directory `/usr/src/linux-2.4.2/kernel'
make CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes
-O2 -fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=athlon  " -C  drivers
make[1]: Entering directory `/usr/src/linux-2.4.2/drivers'
make -C block
make[2]: Entering directory `/usr/src/linux-2.4.2/drivers/block'
make all_targets
make[3]: Entering directory `/usr/src/linux-2.4.2/drivers/block'
gcc -D__KERNEL__ -I/usr/src/linux-2.4/include -Wall -Wstrict-prototypes -O2
-fomit-frame-pointer -fno-strict-aliasing -fno-common -Wno-unused -pipe
-mpreferred-stack-boundary=2 -march=athlon     -c -o floppy.o floppy.cfloppy.c:
In function `fd_ioctl':
floppy.c:3629: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[3]: *** [floppy.o] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.2/drivers/block'
make[2]: *** [first_rule] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.2/drivers/block'
make[1]: *** [_subdir_block] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.2/drivers'
make: *** [_dir_drivers] Error 2
Comment 3 Bernhard Rosenkraenzer 2001-12-06 17:00:23 EST
This is quite likely to be a hardware problem. Is your CPU overclocked? Is all 
your memory OK?

Comment 4 pantelis 2001-12-08 15:49:02 EST
hello.
my CPU is not overclocked.The memory check from BIOS seem ok.
Can you show me a program to test&benchmark the memory?
I've succesfully compiled other programs(eg an RPG Game Nethack)
Comment 5 Jakub Jelinek 2001-12-08 15:56:51 EST
As gcc is deterministic program, random non-reproducible errors are almost
certainly hardware problems.
A good memory tester program is memtest86, you can try that.
Also, due to various flaky chipsets for AMD processors, I'd suggest trying
an i686.rpm kernel instead of .athlon.rpm.

Note You need to log in before you can comment on or make changes to this bug.